summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 6 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 7eb0aef43..d55de30e6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -45,7 +45,8 @@ ifeq ($(DEB_BUILD_ARCH_OS),linux)
CONFIGUREARGS += --enable-nm \
--with-capabilities=libcap \
--enable-farp \
- --enable-dhcp
+ --enable-dhcp \
+ --enable-af-alg
endif
ifeq ($(DEB_BUILD_ARCH_OS),kfreebsd)
@@ -84,6 +85,7 @@ ifeq ($(DEB_BUILD_ARCH_OS),linux)
dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-dhcp.so
dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-farp.so
dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-kernel-netlink.so
+ dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-af-alg.so
endif
ifeq ($(DEB_BUILD_ARCH_OS),kfreebsd)
@@ -109,8 +111,9 @@ endif
-Xlibstrongswan-kernel \
-Xlibstrongswan-dhcp.so \
-Xlibstrongswan-farp.so \
- -Xlibstrongswan-padlock.so \
- -Xlibstrongswan-rdrand.so
+ -Xlibstrongswan-padlock.so \
+ -Xlibstrongswan-rdrand.so \
+ -Xlibstrongswan-af-alg.so
# add additional files not covered by upstream makefile...
install --mode=0600 $(CURDIR)/debian/ipsec.secrets.proto $(CURDIR)/debian/strongswan-starter/etc/ipsec.secrets