summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 9 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index 6bb408ecb..4daf950c1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
#export DEB_LDFLAGS_MAINT_APPEND=-Wl,--as-needed -Wl,-O1 -Wl,-z,defs
export DEB_BUILD_MAINT_OPTIONS=hardening=+pie,+bindnow
-CONFIGUREARGS := --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+CONFIGUREARGS := --libdir=/usr/lib --libexecdir=/usr/lib \
--enable-ldap --enable-curl \
--enable-smartcard --enable-pkcs11 \
--with-default-pkcs11=/usr/lib/$(DEB_HOST_MULTIARCH)/opensc-pkcs11.so \
@@ -75,21 +75,21 @@ override_dh_install:
# first special cases
ifeq ($(DEB_BUILD_ARCH_OS),linux)
# handle Linux-only plugins
- dh_install -p libstrongswan usr/lib/$(DEB_HOST_MULTIARCH)/ipsec/plugins/libstrongswan-dhcp.so
- dh_install -p libstrongswan usr/lib/$(DEB_HOST_MULTIARCH)/ipsec/plugins/libstrongswan-farp.so
- dh_install -p libstrongswan usr/lib/$(DEB_HOST_MULTIARCH)/ipsec/plugins/libstrongswan-xauth.so
- dh_install -p libstrongswan usr/lib/$(DEB_HOST_MULTIARCH)/ipsec/plugins/libstrongswan-kernel-netlink.so
+ dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-dhcp.so
+ dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-farp.so
+ dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-xauth.so
+ dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-kernel-netlink.so
endif
ifeq ($(DEB_BUILD_ARCH_OS),kfreebsd)
# handle FreeBSD-only plugins
- dh_install -p libstrongswan usr/lib/$(DEB_HOST_MULTIARCH)/ipsec/plugins/libstrongswan-kernel-pfkey.so
- dh_install -p libstrongswan usr/lib/$(DEB_HOST_MULTIARCH)/ipsec/plugins/libstrongswan-kernel-pfroute.so
+ dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-kernel-pfkey.so
+ dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-kernel-pfroute.so
endif
ifeq ($(DEB_BUILD_ARCH_CPU),i386)
# special handling for padlock, as it is only built on i386
- dh_install -p libstrongswan usr/lib/$(DEB_HOST_MULTIARCH)/ipsec/plugins/libstrongswan-padlock.so
+ dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-padlock.so
endif
# then install the rest, ignoring the above
@@ -140,7 +140,7 @@ override_dh_fixperms:
dh_fixperms -X etc/ipsec.secrets -X etc/ipsec.d -X var/lib/strongswan
override_dh_makeshlibs:
- dh_makeshlibs -n -X usr/lib/$(DEB_HOST_MULTIARCH)/ipsec/plugins
+ dh_makeshlibs -n -X usr/lib/ipsec/plugins
override_dh_installlogcheck:
dh_installlogcheck --name strongswan