summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules204
1 files changed, 102 insertions, 102 deletions
diff --git a/debian/rules b/debian/rules
index b57711f7a..d0e1090ac 100755
--- a/debian/rules
+++ b/debian/rules
@@ -72,12 +72,12 @@ clean: unpatch
-find $(CURDIR) -name "*.o" | xargs --no-run-if-empty rm
-find $(CURDIR)/lib/libcrypto -name "*.a" | xargs --no-run-if-empty rm
- rm -rf debian/openswan-modules-source-build/
+ rm -rf debian/strongswan-modules-source-build/
# Really clean (#356716)
# This is a hack: should be better implemented
- rm -f lib/libopenswan/libopenswan.a || true
- rm -f lib/libopenswan/liboswlog.a || true
+ rm -f lib/libstrongswan/libstrongswan.a || true
+ rm -f lib/libstrongswan/liboswlog.a || true
# just in case something went wrong
rm -f $(CURDIR)/debian/ipsec.secrets
@@ -92,12 +92,12 @@ ifeq ($(PO2DEBCONF),yes)
# 4.1.16) depends on it), the binary-arch target will generate a
# better version for sarge.
echo 1 > debian/po/output
- po2debconf debian/openswan.templates.master > debian/openswan.templates
+ po2debconf debian/strongswan.templates.master > debian/strongswan.templates
rm -f debian/po/output
endif
-install-openswan: DH_OPTIONS=-a
-install-openswan: build
+install-strongswan: DH_OPTIONS=-a
+install-strongswan: build
dh_testdir
dh_testroot
dh_clean -k
@@ -107,30 +107,30 @@ install-openswan: build
$(MAKE) install INC_USRLOCAL=/usr \
FINALBINDIR=/usr/lib/ipsec \
FINALLIBEXECDIR=/usr/lib/ipsec \
- PUBDIR=$(CURDIR)/debian/openswan/usr/sbin \
- MANTREE=$(CURDIR)/debian/openswan/usr/share/man \
- DESTDIR=$(CURDIR)/debian/openswan
- rm -rf $(CURDIR)/debian/openswan/usr/local
- install --mode=0600 $(CURDIR)/debian/ipsec.secrets.proto $(CURDIR)/debian/openswan/etc/ipsec.secrets
+ PUBDIR=$(CURDIR)/debian/strongswan/usr/sbin \
+ MANTREE=$(CURDIR)/debian/strongswan/usr/share/man \
+ DESTDIR=$(CURDIR)/debian/strongswan
+ rm -rf $(CURDIR)/debian/strongswan/usr/local
+ install --mode=0600 $(CURDIR)/debian/ipsec.secrets.proto $(CURDIR)/debian/strongswan/etc/ipsec.secrets
# use bash for init.d and _plutorun
- patch $(CURDIR)/debian/openswan/etc/init.d/ipsec < debian/use-bash.diff
- patch $(CURDIR)/debian/openswan/usr/lib/ipsec/_plutorun < debian/use-bash.diff
+ patch $(CURDIR)/debian/strongswan/etc/init.d/ipsec < debian/use-bash.diff
+ patch $(CURDIR)/debian/strongswan/usr/lib/ipsec/_plutorun < debian/use-bash.diff
# install the fswcert tool
- install $(CURDIR)/programs/fswcert/fswcert $(CURDIR)/debian/openswan/usr/bin
- install $(CURDIR)/programs/fswcert/fswcert.8 $(CURDIR)/debian/openswan/usr/share/man/man8
+ install $(CURDIR)/programs/fswcert/fswcert $(CURDIR)/debian/strongswan/usr/bin
+ install $(CURDIR)/programs/fswcert/fswcert.8 $(CURDIR)/debian/strongswan/usr/share/man/man8
- rm -f $(CURDIR)/debian/openswan/etc/init.d/ipsec?*
- rm -f $(CURDIR)/debian/openswan/usr/lib/ipsec/_plutorun?*
+ rm -f $(CURDIR)/debian/strongswan/etc/init.d/ipsec?*
+ rm -f $(CURDIR)/debian/strongswan/usr/lib/ipsec/_plutorun?*
# this is handled by update-rc.d
- rm -rf $(CURDIR)/debian/openswan/etc/rc?.d
+ rm -rf $(CURDIR)/debian/strongswan/etc/rc?.d
- dh_installdocs -popenswan -n
+ dh_installdocs -pstrongswan -n
# change the paths in the installed doc files (but only in regular
# files, not in links to the outside of the build tree !)
- ( cd $(CURDIR)/debian/openswan/; \
+ ( cd $(CURDIR)/debian/strongswan/; \
for f in `grep "/usr/local/" --recursive --files-with-match *`; \
do \
if [ -f $$f -a ! -L $$f ]; then \
@@ -140,132 +140,132 @@ install-openswan: build
fi; \
done )
# but remove the doc/src dir, which just duplicates the HTML files
- rm -rf $(CURDIR)/debian/openswan/usr/share/doc/openswan/doc/src
+ rm -rf $(CURDIR)/debian/strongswan/usr/share/doc/strongswan/doc/src
# and the index file in the main doc directory - it's replicated under
# doc/
- rm -f $(CURDIR)/debian/openswan/usr/share/doc/openswan/index.html
+ rm -f $(CURDIR)/debian/strongswan/usr/share/doc/strongswan/index.html
# the logcheck ignore files
- install -D --mode=0600 $(CURDIR)/debian/logcheck.ignore.paranoid $(CURDIR)/debian/openswan/etc/logcheck/ignore.d.paranoid/openswan
- install -D --mode=0600 $(CURDIR)/debian/logcheck.ignore.server $(CURDIR)/debian/openswan/etc/logcheck/ignore.d.server/openswan
- install -D --mode=0600 $(CURDIR)/debian/logcheck.ignore.server $(CURDIR)/debian/openswan/etc/logcheck/ignore.d.workstation/openswan
- install -D --mode=0600 $(CURDIR)/debian/logcheck.violations.ignore $(CURDIR)/debian/openswan/etc/logcheck/violations.ignore.d/openswan
+ install -D --mode=0600 $(CURDIR)/debian/logcheck.ignore.paranoid $(CURDIR)/debian/strongswan/etc/logcheck/ignore.d.paranoid/strongswan
+ install -D --mode=0600 $(CURDIR)/debian/logcheck.ignore.server $(CURDIR)/debian/strongswan/etc/logcheck/ignore.d.server/strongswan
+ install -D --mode=0600 $(CURDIR)/debian/logcheck.ignore.server $(CURDIR)/debian/strongswan/etc/logcheck/ignore.d.workstation/strongswan
+ install -D --mode=0600 $(CURDIR)/debian/logcheck.violations.ignore $(CURDIR)/debian/strongswan/etc/logcheck/violations.ignore.d/strongswan
# set permissions on ipsec.secrets
- chmod 600 $(CURDIR)/debian/openswan/etc/ipsec.secrets
- chmod 644 $(CURDIR)/debian/openswan/etc/ipsec.conf
- chmod 700 -R $(CURDIR)/debian/openswan/etc/ipsec.d/private/
+ chmod 600 $(CURDIR)/debian/strongswan/etc/ipsec.secrets
+ chmod 644 $(CURDIR)/debian/strongswan/etc/ipsec.conf
+ chmod 700 -R $(CURDIR)/debian/strongswan/etc/ipsec.d/private/
# don't know why they come with +x set by default...
- chmod 644 $(CURDIR)/debian/openswan/etc/ipsec.d/policies/*
- chmod 644 $(CURDIR)/debian/openswan/etc/ipsec.d/examples/*
+ chmod 644 $(CURDIR)/debian/strongswan/etc/ipsec.d/policies/*
+ chmod 644 $(CURDIR)/debian/strongswan/etc/ipsec.d/examples/*
# more lintian cleanups
- find $(CURDIR)/debian/openswan -name ".cvsignore" | xargs --no-run-if-empty rm -f
- find $(CURDIR)/debian/openswan -name "/.svn/" | xargs --no-run-if-empty rm -rf
+ find $(CURDIR)/debian/strongswan -name ".cvsignore" | xargs --no-run-if-empty rm -f
+ find $(CURDIR)/debian/strongswan -name "/.svn/" | xargs --no-run-if-empty rm -rf
-install-openswan-modules-source: DH_OPTIONS=-i
-install-openswan-modules-source: PKGDIR=$(CURDIR)/debian/openswan-modules-source
-install-openswan-modules-source: BUILDDIR=$(CURDIR)/debian/openswan-modules-source-build
-install-openswan-modules-source: patch
+install-strongswan-modules-source: DH_OPTIONS=-i
+install-strongswan-modules-source: PKGDIR=$(CURDIR)/debian/strongswan-modules-source
+install-strongswan-modules-source: BUILDDIR=$(CURDIR)/debian/strongswan-modules-source-build
+install-strongswan-modules-source: patch
dh_testdir
dh_testroot
dh_installdirs
- mkdir -p "$(BUILDDIR)/modules/openswan"
- mkdir -p "$(BUILDDIR)/modules/openswan/lib"
- mkdir -p "$(BUILDDIR)/modules/openswan/debian"
- mkdir -p "$(BUILDDIR)/modules/openswan/packaging"
+ mkdir -p "$(BUILDDIR)/modules/strongswan"
+ mkdir -p "$(BUILDDIR)/modules/strongswan/lib"
+ mkdir -p "$(BUILDDIR)/modules/strongswan/debian"
+ mkdir -p "$(BUILDDIR)/modules/strongswan/packaging"
cp -r Makefile Makefile.top Makefile.inc Makefile.ver linux/ \
- "$(BUILDDIR)/modules/openswan"
- cp -r lib/libcrypto "$(BUILDDIR)/modules/openswan/lib/"
+ "$(BUILDDIR)/modules/strongswan"
+ cp -r lib/libcrypto "$(BUILDDIR)/modules/strongswan/lib/"
cp -r packaging/makefiles packaging/linus packaging/defaults/ \
- "$(BUILDDIR)/modules/openswan/packaging/"
- find "$(BUILDDIR)/modules/openswan/lib/" -name "*.o" | xargs --no-run-if-empty rm
- install --mode=644 debian/openswan-modules-source.kernel-config "$(BUILDDIR)/modules/openswan/config-all.h"
- install --mode=755 debian/openswan-modules-source.rules "$(BUILDDIR)/modules/openswan/debian/rules"
- install --mode=644 debian/openswan-modules-source.control.in "$(BUILDDIR)/modules/openswan/debian/control.in"
- install --mode=644 debian/changelog "$(BUILDDIR)/modules/openswan/debian/"
+ "$(BUILDDIR)/modules/strongswan/packaging/"
+ find "$(BUILDDIR)/modules/strongswan/lib/" -name "*.o" | xargs --no-run-if-empty rm
+ install --mode=644 debian/strongswan-modules-source.kernel-config "$(BUILDDIR)/modules/strongswan/config-all.h"
+ install --mode=755 debian/strongswan-modules-source.rules "$(BUILDDIR)/modules/strongswan/debian/rules"
+ install --mode=644 debian/strongswan-modules-source.control.in "$(BUILDDIR)/modules/strongswan/debian/control.in"
+ install --mode=644 debian/changelog "$(BUILDDIR)/modules/strongswan/debian/"
# This creates the NAT-T patches that can be used on the kernel tree
- # even with openswan-modules-source.
- make nattpatch2.4 > $(BUILDDIR)/modules/openswan/debian/nat-t-2.4.diff
- make nattpatch2.6 > $(BUILDDIR)/modules/openswan/debian/nat-t-2.6.diff
+ # even with strongswan-modules-source.
+ make nattpatch2.4 > $(BUILDDIR)/modules/strongswan/debian/nat-t-2.4.diff
+ make nattpatch2.6 > $(BUILDDIR)/modules/strongswan/debian/nat-t-2.6.diff
tar -C $(BUILDDIR) -c modules/ | bzip2 -9 > \
- "$(PKGDIR)/usr/src/openswan-modules.tar.bz2"
+ "$(PKGDIR)/usr/src/strongswan-modules.tar.bz2"
- dh_installdocs -popenswan-modules-source -n
+ dh_installdocs -pstrongswan-modules-source -n
# more lintian cleanups
- find $(CURDIR)/debian/openswan-modules-source -name ".cvsignore" | xargs --no-run-if-empty rm -f
+ find $(CURDIR)/debian/strongswan-modules-source -name ".cvsignore" | xargs --no-run-if-empty rm -f
find $(PKGDIR) -name "/.svn/" | xargs --no-run-if-empty rm -rf
-install-linux-patch-openswan: DH_OPTIONS=-i
-install-linux-patch-openswan: PKGDIR=$(CURDIR)/debian/linux-patch-openswan
-install-linux-patch-openswan: patch
+install-linux-patch-strongswan: DH_OPTIONS=-i
+install-linux-patch-strongswan: PKGDIR=$(CURDIR)/debian/linux-patch-strongswan
+install-linux-patch-strongswan: patch
dh_testdir
dh_testroot
dh_installdirs
# some of this has been taken from Tommi Virtanen's package
- install --mode=0755 debian/linux-patch-openswan.apply \
- "$(PKGDIR)/usr/src/kernel-patches/all/apply/openswan"
- install --mode=0755 debian/linux-patch-openswan.unpatch \
- "$(PKGDIR)/usr/src/kernel-patches/all/unpatch/openswan"
+ install --mode=0755 debian/linux-patch-strongswan.apply \
+ "$(PKGDIR)/usr/src/kernel-patches/all/apply/strongswan"
+ install --mode=0755 debian/linux-patch-strongswan.unpatch \
+ "$(PKGDIR)/usr/src/kernel-patches/all/unpatch/strongswan"
install --mode=0755 packaging/utils/patcher \
- "$(PKGDIR)/usr/src/kernel-patches/all/openswan"
+ "$(PKGDIR)/usr/src/kernel-patches/all/strongswan"
cp -r Makefile Makefile.inc Makefile.ver Makefile.top lib/ linux/ \
packaging/ nat-t/ \
- "$(PKGDIR)/usr/src/kernel-patches/all/openswan"
+ "$(PKGDIR)/usr/src/kernel-patches/all/strongswan"
# also don't generate the out.kpatch file under /usr/src/....
sed 's/>>out.kpatch//' \
- "$(PKGDIR)/usr/src/kernel-patches/all/openswan/Makefile" \
- > "$(PKGDIR)/usr/src/kernel-patches/all/openswan/Makefile.tmp"
- mv "$(PKGDIR)/usr/src/kernel-patches/all/openswan/Makefile.tmp" \
- "$(PKGDIR)/usr/src/kernel-patches/all/openswan/Makefile"
+ "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/Makefile" \
+ > "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/Makefile.tmp"
+ mv "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/Makefile.tmp" \
+ "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/Makefile"
sed 's/>out.kpatch//' \
- "$(PKGDIR)/usr/src/kernel-patches/all/openswan/Makefile" \
- > "$(PKGDIR)/usr/src/kernel-patches/all/openswan/Makefile.tmp"
- mv "$(PKGDIR)/usr/src/kernel-patches/all/openswan/Makefile.tmp" \
- "$(PKGDIR)/usr/src/kernel-patches/all/openswan/Makefile"
+ "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/Makefile" \
+ > "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/Makefile.tmp"
+ mv "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/Makefile.tmp" \
+ "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/Makefile"
sed 's/rm -f out.kpatch//' \
- "$(PKGDIR)/usr/src/kernel-patches/all/openswan/Makefile" \
- > "$(PKGDIR)/usr/src/kernel-patches/all/openswan/Makefile.tmp"
- mv "$(PKGDIR)/usr/src/kernel-patches/all/openswan/Makefile.tmp" \
- "$(PKGDIR)/usr/src/kernel-patches/all/openswan/Makefile"
- chmod u=rwX,go=rX "$(PKGDIR)/usr/src/kernel-patches/all/openswan"
+ "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/Makefile" \
+ > "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/Makefile.tmp"
+ mv "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/Makefile.tmp" \
+ "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/Makefile"
+ chmod u=rwX,go=rX "$(PKGDIR)/usr/src/kernel-patches/all/strongswan"
# remove extra junk not needed on linux / that lintian would complain about
- find "$(PKGDIR)/usr/src/kernel-patches/all/openswan" \
+ find "$(PKGDIR)/usr/src/kernel-patches/all/strongswan" \
-name '*.o' -print0 | xargs --no-run-if-empty -0 rm -f
- find "$(PKGDIR)/usr/src/kernel-patches/all/openswan" \
+ find "$(PKGDIR)/usr/src/kernel-patches/all/strongswan" \
-name '*.a' -print0 | xargs --no-run-if-empty -0 rm -f
- rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/openswan/lib/libopenswan/"
- rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/openswan/lib/libdes/"
- rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/openswan/lib/liblwres/"
- rm -f "$(PKGDIR)/usr/src/kernel-patches/all/openswan/lib/COPYING.LIB"
- rm -f "$(PKGDIR)/usr/src/kernel-patches/all/openswan/lib/README"
- rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/openswan/packaging/linus"
- rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/openswan/packaging/ipkg"
- rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/openswan/packaging/makefiles"
- rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/openswan/packaging/redhat"
- rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/openswan/packaging/suse"
- rm -r "$(PKGDIR)/usr/src/kernel-patches/all/openswan/packaging/utils/disttools.pl"
- rm -r "$(PKGDIR)/usr/src/kernel-patches/all/openswan/packaging/utils/kernel.patch.gen.sh"
- rm -r "$(PKGDIR)/usr/src/kernel-patches/all/openswan/packaging/utils/sshenv"
- rm -r "$(PKGDIR)/usr/src/kernel-patches/all/openswan/packaging/utils/setup"
- find "$(PKGDIR)/usr/src/kernel-patches/all/openswan/linux/net/ipsec/des/asm/" \
+ rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/lib/libstrongswan/"
+ rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/lib/libdes/"
+ rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/lib/liblwres/"
+ rm -f "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/lib/COPYING.LIB"
+ rm -f "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/lib/README"
+ rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/packaging/linus"
+ rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/packaging/ipkg"
+ rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/packaging/makefiles"
+ rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/packaging/redhat"
+ rm -rf "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/packaging/suse"
+ rm -r "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/packaging/utils/disttools.pl"
+ rm -r "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/packaging/utils/kernel.patch.gen.sh"
+ rm -r "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/packaging/utils/sshenv"
+ rm -r "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/packaging/utils/setup"
+ find "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/linux/net/ipsec/des/asm/" \
-name '*.pl' -print0 | xargs --no-run-if-empty -0 \
perl -pi -e 's{^#!/usr/local/bin/perl}{#!/usr/bin/perl}g'
- find "$(PKGDIR)/usr/src/kernel-patches/all/openswan/lib/libcrypto/" \
+ find "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/lib/libcrypto/" \
-name '*.pl' -print0 | xargs --no-run-if-empty -0 \
perl -pi -e 's{^#!/usr/local/bin/perl}{#!/usr/bin/perl}g'
- find "$(PKGDIR)/usr/src/kernel-patches/all/openswan/linux/net/ipsec/des/asm/" \
+ find "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/linux/net/ipsec/des/asm/" \
-name '*.pl' -print0 | xargs --no-run-if-empty -0 chmod a+x
- find "$(PKGDIR)/usr/src/kernel-patches/all/openswan/lib/libcrypto/" \
+ find "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/lib/libcrypto/" \
-name '*.pl' -print0 | xargs --no-run-if-empty -0 chmod a+x
- find "$(PKGDIR)/usr/src/kernel-patches/all/openswan/linux/net/ipsec/alg/scripts/" \
+ find "$(PKGDIR)/usr/src/kernel-patches/all/strongswan/linux/net/ipsec/alg/scripts/" \
-name '*.sh' -print0 | xargs --no-run-if-empty -0 chmod a+x
- chmod -R u=rwX,go=rX "$(PKGDIR)/usr/src/kernel-patches/all/openswan"
+ chmod -R u=rwX,go=rX "$(PKGDIR)/usr/src/kernel-patches/all/strongswan"
- dh_installdocs -plinux-patch-openswan -n
+ dh_installdocs -plinux-patch-strongswan -n
# more lintian cleanups
find $(PKGDIR) -name ".cvsignore" | xargs --no-run-if-empty rm -f
@@ -291,11 +291,11 @@ binary-common:
dh_builddeb
# Build architecture-independent files here.
-binary-indep: install-openswan-modules-source install-linux-patch-openswan
+binary-indep: install-strongswan-modules-source install-linux-patch-strongswan
$(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
# Build architecture-dependent files here.
-binary-arch: install-openswan
+binary-arch: install-strongswan
$(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
# Any other binary targets build just one binary package at a time.