summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rwxr-xr-xdebian/rules5
-rw-r--r--debian/strongswan.postrm6
3 files changed, 16 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 584e44338..b2515cc6f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,11 @@
strongswan (4.2.12-1) unstable; urgency=low
* New upstream release
+ * Explicitly remove directories /etc/ipsec.d and /var/run/pluto on purge.
+ * No longer mark ipsec.conf and ipsec.secrets as conffiles, as they
+ are modified by postinst. Although I don't particularly like this
+ method of patching DEBIAN/conffiles, I don't have a better solution
+ right now. Thus take patch from Mathieu Parent.
-- Rene Mayrhofer <rmayr@debian.org> Sun, 01 Mar 2009 10:46:08 +0000
diff --git a/debian/rules b/debian/rules
index 7bf35273d..618717875 100755
--- a/debian/rules
+++ b/debian/rules
@@ -146,6 +146,11 @@ binary-common:
dh_fixperms -X etc/ipsec.secrets -X etc/ipsec.d
dh_makeshlibs
dh_installdeb
+ifeq ($(DH_OPTIONS), -a)
+ # /etc/ipsec.{conf,secrets} are not conffiles (#515095)
+ egrep -v '^/etc/ipsec.(conf|secrets)' debian/openswan/DEBIAN/conffiles > debian/openswan/DEBIAN/conffiles.new
+ mv debian/openswan/DEBIAN/conffiles.new debian/openswan/DEBIAN/conffiles
+endif
dh_shlibdeps
dh_gencontrol
dh_md5sums
diff --git a/debian/strongswan.postrm b/debian/strongswan.postrm
index e42af1082..18f9069b6 100644
--- a/debian/strongswan.postrm
+++ b/debian/strongswan.postrm
@@ -30,6 +30,12 @@ case "$1" in
esac
+if [ "$1" = "purge" ] ; then
+ update-rc.d ipsec remove >/dev/null
+ rm -rf /etc/ipsec.d/
+ rm -rf /var/run/pluto/
+fi
+
# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.