summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am17
1 files changed, 5 insertions, 12 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 0becd24c7..266ef7d3a 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -1,13 +1,6 @@
-dist_man_MANS = ipsec.conf.5 ipsec.secrets.5 strongswan.conf.5
-EXTRA_DIST = ipsec.conf.5.in ipsec.secrets.5.in strongswan.conf.5.in
-CLEANFILES = ipsec.conf.5 ipsec.secrets.5 strongswan.conf.5
+man_MANS = \
+ ipsec.conf.5 \
+ ipsec.secrets.5 \
+ strongswan.conf.5
-SUFFIXES = .in
-
-.in:
- $(AM_V_GEN) \
- sed \
- -e "s:@IPSEC_VERSION@:$(PACKAGE_VERSION):" \
- -e "s:@DEV_URANDOM@:$(urandom_device):" \
- -e "s:@DEV_RANDOM@:$(random_device):" \
- $(srcdir)/$@.in > $@
+CLEANFILES = $(man_MANS)