summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0edddc9fc..cd75de5e9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,8 +16,16 @@ if USE_TLS
SUBDIRS += libtls
endif
+if USE_LIBCHARON
+ SUBDIRS += libcharon
+endif
+
if USE_FILE_CONFIG
- SUBDIRS += libfreeswan starter ipsec _copyright
+ SUBDIRS += libfreeswan starter
+endif
+
+if USE_IPSEC_SCRIPT
+ SUBDIRS += ipsec _copyright
endif
if USE_PLUTO
@@ -25,7 +33,7 @@ if USE_PLUTO
endif
if USE_CHARON
- SUBDIRS += libcharon charon
+ SUBDIRS += charon
endif
if USE_STROKE
@@ -40,6 +48,10 @@ if USE_TOOLS
SUBDIRS += libfreeswan openac scepclient pki
endif
+if USE_CONFTEST
+ SUBDIRS += conftest
+endif
+
if USE_DUMM
SUBDIRS += dumm
endif
@@ -64,4 +76,4 @@ EXTRA_DIST = strongswan.conf
install-exec-local :
test -e "$(DESTDIR)${sysconfdir}" || $(INSTALL) -d "$(DESTDIR)$(sysconfdir)"
- test -e "$(DESTDIR)$(sysconfdir)/strongswan.conf" || $(INSTALL) -o ${ipsecuid} -g ${ipsecgid} -m 640 $(srcdir)/strongswan.conf $(DESTDIR)$(sysconfdir)/strongswan.conf || true
+ test -e "$(DESTDIR)$(sysconfdir)/strongswan.conf" || $(INSTALL) -m 640 $(srcdir)/strongswan.conf $(DESTDIR)$(sysconfdir)/strongswan.conf || true