summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 93da4893f..95c68d0c8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -72,8 +72,16 @@ if USE_UPDOWN
SUBDIRS += _updown _updown_espmark
endif
-if USE_TOOLS
- SUBDIRS += scepclient pki
+if USE_SCEPCLIENT
+ SUBDIRS += scepclient
+endif
+
+if USE_PKI
+ SUBDIRS += pki
+endif
+
+if USE_SWANCTL
+ SUBDIRS += swanctl
endif
if USE_CONFTEST
@@ -112,6 +120,10 @@ if USE_CMD
SUBDIRS += charon-cmd
endif
+if USE_SVC
+ SUBDIRS += charon-svc
+endif
+
if USE_LIBPTTLS
SUBDIRS += pt-tls-client
endif
@@ -119,3 +131,7 @@ endif
if USE_INTEGRITY_TEST
SUBDIRS += checksum
endif
+
+if USE_AIKGEN
+ SUBDIRS += aikgen
+endif