summaryrefslogtreecommitdiff
path: root/src/_updown/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/_updown/Makefile.am')
-rw-r--r--src/_updown/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/_updown/Makefile.am b/src/_updown/Makefile.am
index 27a467c4f..d0b7a27a4 100644
--- a/src/_updown/Makefile.am
+++ b/src/_updown/Makefile.am
@@ -1,3 +1,11 @@
-dist_ipsec_SCRIPTS = _updown
+ipsec_SCRIPTS = _updown
+CLEANFILES = _updown
dist_man8_MANS = _updown.8
+EXTRA_DIST = _updown.in
+_updown : _updown.in
+ sed \
+ -e "s:\@IPSEC_ROUTING_TABLE\@:$(IPSEC_ROUTING_TABLE):" \
+ -e "s:\@IPSEC_ROUTING_TABLE_PRIO\@:$(IPSEC_ROUTING_TABLE_PRIO):" \
+ $< > $@
+ chmod +x $@