summaryrefslogtreecommitdiff
path: root/src/charon/plugins/nm/gnome/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/charon/plugins/nm/gnome/Makefile.am')
-rw-r--r--src/charon/plugins/nm/gnome/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/charon/plugins/nm/gnome/Makefile.am b/src/charon/plugins/nm/gnome/Makefile.am
new file mode 100644
index 000000000..62d28e438
--- /dev/null
+++ b/src/charon/plugins/nm/gnome/Makefile.am
@@ -0,0 +1,24 @@
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = properties auth-dialog po
+
+dbusservicedir = $(sysconfdir)/dbus-1/system.d
+dbusservice_DATA = nm-strongswan-service.conf
+
+nmvpnservicedir = $(sysconfdir)/NetworkManager/VPN
+nmvpnservice_DATA = nm-strongswan-service.name
+
+@INTLTOOL_DESKTOP_RULE@
+
+nm-strongswan-service.name: $(srcdir)/nm-strongswan-service.name.in
+ sed -e 's|[@]LIBEXECDIR[@]|$(libexecdir)|' \
+ -e 's|[@]CHARON[@]|$(charon)|' $< >$@
+
+EXTRA_DIST = nm-strongswan-service.name.in \
+ $(dbusservice_DATA) \
+ intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in
+
+CLEANFILES = $(nmvpnservice_DATA) *~
+DISTCLEANFILES = intltool-extract intltool-merge intltool-update