summaryrefslogtreecommitdiff
path: root/src/charon/plugins/resolv_conf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/charon/plugins/resolv_conf/Makefile.am')
-rw-r--r--src/charon/plugins/resolv_conf/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/charon/plugins/resolv_conf/Makefile.am b/src/charon/plugins/resolv_conf/Makefile.am
new file mode 100644
index 000000000..917964f93
--- /dev/null
+++ b/src/charon/plugins/resolv_conf/Makefile.am
@@ -0,0 +1,13 @@
+
+INCLUDES = -I$(top_srcdir)/src/libstrongswan -I$(top_srcdir)/src/charon
+
+AM_CFLAGS = -rdynamic \
+ -DRESOLV_CONF=\"${resolv_conf}\"
+
+plugin_LTLIBRARIES = libstrongswan-resolv-conf.la
+libstrongswan_resolv_conf_la_SOURCES = \
+ resolv_conf_plugin.h resolv_conf_plugin.c \
+ resolv_conf_handler.h resolv_conf_handler.c
+libstrongswan_resolv_conf_la_LDFLAGS = -module
+
+