summaryrefslogtreecommitdiff
path: root/src/checksum/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/checksum/Makefile.am')
-rw-r--r--src/checksum/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/checksum/Makefile.am b/src/checksum/Makefile.am
index 82bbadcf1..821c51747 100644
--- a/src/checksum/Makefile.am
+++ b/src/checksum/Makefile.am
@@ -22,7 +22,7 @@ AM_CPPFLAGS = \
-DPLUGINDIR=\"${DESTDIR}${plugindir}\"
AM_CFLAGS = \
- -rdynamic
+ $(PLUGIN_CFLAGS)
# we keep track of build dependencies in deps and use libs to store the paths
# to the installed libraries. for executables we use the built files directly
@@ -99,11 +99,18 @@ if USE_CMD
exes += $(DESTDIR)$(sbindir)/charon-cmd
endif
-if USE_TOOLS
+if USE_SCEPCLIENT
exes += $(DESTDIR)$(ipsecdir)/scepclient
+endif
+
+if USE_PKI
exes += $(DESTDIR)$(bindir)/pki
endif
+if USE_SWANCTL
+ exes += $(DESTDIR)$(sbindir)/swanctl
+endif
+
if USE_ATTR_SQL
exes += $(DESTDIR)$(ipsecdir)/pool
endif