summaryrefslogtreecommitdiff
path: root/src/conftest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/conftest/Makefile.am')
-rw-r--r--src/conftest/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/conftest/Makefile.am b/src/conftest/Makefile.am
index 64a2cc6d3..2aafc7a6f 100644
--- a/src/conftest/Makefile.am
+++ b/src/conftest/Makefile.am
@@ -1,6 +1,9 @@
ipsec_PROGRAMS = conftest
-AM_CFLAGS = -rdynamic \
+AM_CPPFLAGS = -rdynamic \
+ -I$(top_srcdir)/src/libstrongswan \
+ -I$(top_srcdir)/src/libhydra \
+ -I$(top_srcdir)/src/libcharon \
-DPLUGINS=\""${charon_plugins}\""
conftest_SOURCES = conftest.c conftest.h config.c config.h actions.c actions.h \
@@ -13,11 +16,6 @@ conftest_SOURCES = conftest.c conftest.h config.c config.h actions.c actions.h \
hooks/set_ike_request.c hooks/set_reserved.c hooks/set_ike_initiator.c \
hooks/log_ts.c hooks/rebuild_auth.c hooks/reset_seq.c
-INCLUDES = \
- -I$(top_srcdir)/src/libstrongswan \
- -I$(top_srcdir)/src/libhydra \
- -I$(top_srcdir)/src/libcharon
-
conftest_LDADD = \
$(top_builddir)/src/libstrongswan/libstrongswan.la \
$(top_builddir)/src/libhydra/libhydra.la \