summaryrefslogtreecommitdiff
path: root/src/dumm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dumm/Makefile.am')
-rw-r--r--src/dumm/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/src/dumm/Makefile.am b/src/dumm/Makefile.am
index 029290fb6..b7fb3f7c8 100644
--- a/src/dumm/Makefile.am
+++ b/src/dumm/Makefile.am
@@ -1,4 +1,4 @@
-EXTRA_DIST = ext/dumm.c ext/extconf.rb ext/README \
+EXTRA_DIST = ext/dumm.c ext/README \
ext/lib/dumm.rb ext/lib/dumm/guest.rb
lib_LTLIBRARIES = libdumm.la
@@ -15,5 +15,18 @@ dumm_LDADD = libdumm.la ${gtk_LIBS}
irdumm_LDADD = libdumm.la -lruby1.8
INCLUDES = -I$(top_srcdir)/src/libstrongswan ${gtk_CFLAGS} \
- -I/usr/lib/ruby/1.8/i486-linux/
+ ${RUBYINCLUDE}
AM_CFLAGS = -D_FILE_OFFSET_BITS=64
+
+all-local: ext
+
+clean-local:
+ (test -f ext/Makefile && cd ext && $(MAKE) clean && rm Makefile || true)
+
+install-data-local:
+ (test -f ext/Makefile && cd ext && $(MAKE) install)
+
+ext: libdumm.la
+ (cd ext && $(RUBY) extconf.rb && $(MAKE))
+
+.PHONY: ext