summaryrefslogtreecommitdiff
path: root/src/ipsec/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/ipsec/Makefile.am')
-rw-r--r--src/ipsec/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/ipsec/Makefile.am b/src/ipsec/Makefile.am
index f3ca1ca06..510f1021a 100644
--- a/src/ipsec/Makefile.am
+++ b/src/ipsec/Makefile.am
@@ -1,7 +1,12 @@
sbin_SCRIPTS = ipsec
-CLEANFILES = ipsec
+CLEANFILES = ipsec ipsec.8
dist_man8_MANS = ipsec.8
-EXTRA_DIST = ipsec.in
+EXTRA_DIST = ipsec.in ipsec.8.in
+
+ipsec.8 : ipsec.8.in
+ sed \
+ -e "s:@IPSEC_VERSION@:$(PACKAGE_VERSION):" \
+ $(srcdir)/$@.in > $@
ipsec : ipsec.in
sed \
@@ -10,7 +15,7 @@ ipsec : ipsec.in
-e "s:@IPSEC_DISTRO@::" \
-e "s:@IPSEC_DIR@:$(ipsecdir):" \
-e "s:@IPSEC_SBINDIR@:$(sbindir):" \
- -e "s:@IPSEC_CONFDIR@:$(confdir):" \
+ -e "s:@IPSEC_CONFDIR@:$(sysconfdir):" \
-e "s:@IPSEC_PIDDIR@:$(piddir):" \
$(srcdir)/$@.in > $@
chmod +x $@