summaryrefslogtreecommitdiff
path: root/src/libcharon/plugins/dnscert/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libcharon/plugins/dnscert/Makefile.am')
-rw-r--r--src/libcharon/plugins/dnscert/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/libcharon/plugins/dnscert/Makefile.am b/src/libcharon/plugins/dnscert/Makefile.am
new file mode 100644
index 000000000..51d542b30
--- /dev/null
+++ b/src/libcharon/plugins/dnscert/Makefile.am
@@ -0,0 +1,20 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/libstrongswan \
+ -I$(top_srcdir)/src/libhydra \
+ -I$(top_srcdir)/src/libcharon
+
+AM_CFLAGS = \
+ -rdynamic
+
+if MONOLITHIC
+noinst_LTLIBRARIES = libstrongswan-dnscert.la
+else
+plugin_LTLIBRARIES = libstrongswan-dnscert.la
+endif
+
+libstrongswan_dnscert_la_SOURCES = \
+ dnscert_plugin.h dnscert_plugin.c \
+ dnscert_cred.h dnscert_cred.c \
+ dnscert.h dnscert.c
+
+libstrongswan_dnscert_la_LDFLAGS = -module -avoid-version