summaryrefslogtreecommitdiff
path: root/src/libcharon/plugins/duplicheck/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libcharon/plugins/duplicheck/Makefile.am')
-rw-r--r--src/libcharon/plugins/duplicheck/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/src/libcharon/plugins/duplicheck/Makefile.am b/src/libcharon/plugins/duplicheck/Makefile.am
index 63c91dfab..4ea2becf3 100644
--- a/src/libcharon/plugins/duplicheck/Makefile.am
+++ b/src/libcharon/plugins/duplicheck/Makefile.am
@@ -1,10 +1,12 @@
-
-INCLUDES = -I$(top_srcdir)/src/libstrongswan -I$(top_srcdir)/src/libhydra \
- -I$(top_srcdir)/src/libcharon
-
-AM_CFLAGS = -rdynamic \
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/libstrongswan \
+ -I$(top_srcdir)/src/libhydra \
+ -I$(top_srcdir)/src/libcharon \
-DIPSEC_PIDDIR=\"${piddir}\"
+AM_CFLAGS = \
+ -rdynamic
+
if MONOLITHIC
noinst_LTLIBRARIES = libstrongswan-duplicheck.la
else
@@ -13,7 +15,8 @@ endif
libstrongswan_duplicheck_la_SOURCES = duplicheck_plugin.h duplicheck_plugin.c \
duplicheck_listener.h duplicheck_listener.c \
- duplicheck_notify.h duplicheck_notify.c
+ duplicheck_notify.h duplicheck_notify.c \
+ duplicheck_msg.h
libstrongswan_duplicheck_la_LDFLAGS = -module -avoid-version