summaryrefslogtreecommitdiff
path: root/src/libcrypto/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libcrypto/Makefile.am')
-rw-r--r--src/libcrypto/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/libcrypto/Makefile.am b/src/libcrypto/Makefile.am
new file mode 100644
index 000000000..23066033d
--- /dev/null
+++ b/src/libcrypto/Makefile.am
@@ -0,0 +1,11 @@
+noinst_LIBRARIES = libcrypto.a
+libcrypto_a_SOURCES = \
+libaes/aes_xcbc_mac.c libaes/aes_cbc.c libaes/aes_xcbc_mac.h libaes/aes_cbc.h libaes/aes.c libaes/aes.h \
+include/md32_common.h include/cbc_generic.h include/hmac_generic.h libblowfish/bf_skey.c libblowfish/blowfish.h \
+libblowfish/bf_pi.h libblowfish/bf_locl.h libblowfish/bf_enc.c libsha2/hmac_sha2.c libsha2/sha2.h libsha2/hmac_sha2.h \
+libsha2/sha2.c libserpent/serpent_cbc.c libserpent/serpent_cbc.h libserpent/serpent.c libserpent/serpent.h \
+libtwofish/twofish_cbc.h libtwofish/twofish_cbc.c libtwofish/twofish.c libtwofish/twofish.h libdes/des_enc.c \
+libdes/podd.h libdes/sk.h libdes/set_key.c libdes/speed.c libdes/fcrypt_b.c libdes/fcrypt.c libdes/destest.c \
+libdes/spr.h libdes/cbc_enc.c libdes/ecb_enc.c libdes/des_opts.c libdes/des_locl.h libdes/des_ver.h libdes/des.h
+
+INCLUDES = -I$(top_srcdir)/src/libcrypto/include