summaryrefslogtreecommitdiff
path: root/src/libstrongswan/math/libnttfft/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libstrongswan/math/libnttfft/Makefile.am')
-rw-r--r--src/libstrongswan/math/libnttfft/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/libstrongswan/math/libnttfft/Makefile.am b/src/libstrongswan/math/libnttfft/Makefile.am
new file mode 100644
index 000000000..ec98abead
--- /dev/null
+++ b/src/libstrongswan/math/libnttfft/Makefile.am
@@ -0,0 +1,15 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/libstrongswan
+
+AM_CFLAGS = \
+ @COVERAGE_CFLAGS@
+
+AM_LDFLAGS = \
+ -no-undefined
+
+ipseclib_LTLIBRARIES = libnttfft.la
+
+libnttfft_la_SOURCES = \
+ ntt_fft_reduce.h ntt_fft.h ntt_fft.c \
+ ntt_fft_params.h ntt_fft_params.c
+