summaryrefslogtreecommitdiff
path: root/src/libstrongswan/plugins/agent/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libstrongswan/plugins/agent/Makefile.am')
-rw-r--r--src/libstrongswan/plugins/agent/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/libstrongswan/plugins/agent/Makefile.am b/src/libstrongswan/plugins/agent/Makefile.am
new file mode 100644
index 000000000..bc022aa26
--- /dev/null
+++ b/src/libstrongswan/plugins/agent/Makefile.am
@@ -0,0 +1,12 @@
+
+INCLUDES = -I$(top_srcdir)/src/libstrongswan
+
+AM_CFLAGS = -rdynamic
+
+plugin_LTLIBRARIES = libstrongswan-agent.la
+
+libstrongswan_agent_la_SOURCES = agent_plugin.h agent_plugin.c \
+ agent_private_key.c agent_private_key.h
+
+libstrongswan_agent_la_LDFLAGS = -module
+