summaryrefslogtreecommitdiff
path: root/src/libstrongswan/plugins/gcrypt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libstrongswan/plugins/gcrypt/Makefile.am')
-rw-r--r--src/libstrongswan/plugins/gcrypt/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/libstrongswan/plugins/gcrypt/Makefile.am b/src/libstrongswan/plugins/gcrypt/Makefile.am
new file mode 100644
index 000000000..72cc409fc
--- /dev/null
+++ b/src/libstrongswan/plugins/gcrypt/Makefile.am
@@ -0,0 +1,17 @@
+
+INCLUDES = -I$(top_srcdir)/src/libstrongswan
+
+AM_CFLAGS = -rdynamic $(LIBGCRYPT_CFLAGS)
+
+plugin_LTLIBRARIES = libstrongswan-gcrypt.la
+
+libstrongswan_gcrypt_la_SOURCES = gcrypt_plugin.h gcrypt_plugin.c \
+ gcrypt_rsa_public_key.h gcrypt_rsa_public_key.c \
+ gcrypt_rsa_private_key.h gcrypt_rsa_private_key.c \
+ gcrypt_dh.h gcrypt_dh.c \
+ gcrypt_rng.h gcrypt_rng.c \
+ gcrypt_crypter.h gcrypt_crypter.c \
+ gcrypt_hasher.h gcrypt_hasher.c
+
+libstrongswan_gcrypt_la_LDFLAGS = -module
+libstrongswan_gcrypt_la_LIBADD = $(LIBGCRYPT_LIBS)