summaryrefslogtreecommitdiff
path: root/src/libtpmtss/plugins/tpm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libtpmtss/plugins/tpm/Makefile.am')
-rw-r--r--src/libtpmtss/plugins/tpm/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/libtpmtss/plugins/tpm/Makefile.am b/src/libtpmtss/plugins/tpm/Makefile.am
new file mode 100644
index 000000000..281281022
--- /dev/null
+++ b/src/libtpmtss/plugins/tpm/Makefile.am
@@ -0,0 +1,21 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/libstrongswan \
+ -I$(top_srcdir)/src/libtpmtss
+
+AM_CFLAGS = \
+ $(PLUGIN_CFLAGS)
+
+if MONOLITHIC
+noinst_LTLIBRARIES = libstrongswan-tpm.la
+else
+plugin_LTLIBRARIES = libstrongswan-tpm.la
+libstrongswan_tpm_la_LIBADD = \
+ $(top_builddir)/src/libtpmtss/libtpmtss.la
+endif
+
+libstrongswan_tpm_la_SOURCES = \
+ tpm_plugin.h tpm_plugin.c \
+ tpm_private_key.h tpm_private_key.c \
+ tpm_rng.h tpm_rng.c
+
+libstrongswan_tpm_la_LDFLAGS = -module -avoid-version