summaryrefslogtreecommitdiff
path: root/src/scepclient/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/scepclient/Makefile.am')
-rw-r--r--src/scepclient/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/src/scepclient/Makefile.am b/src/scepclient/Makefile.am
index 3a5f9839f..57b20dfb5 100644
--- a/src/scepclient/Makefile.am
+++ b/src/scepclient/Makefile.am
@@ -23,16 +23,18 @@ scepclient_LDADD = asn1.o ca.o crl.o certs.o constants.o defs.o fetch.o id.o \
$(LIBFREESWANDIR)/libfreeswan.a $(LIBCRYPTODIR)/libcrypto.a \
-lgmp
-# This compile option activates dynamic URL fetching using libcurl
-if USE_LIBCURL
- scepclient_LDADD += -lcurl
-endif
-
# This compile option activates smartcard support
if USE_SMARTCARD
+ AM_CFLAGS += -DSMARTCARD
scepclient_LDADD += -ldl
endif
+# This compile option activates dynamic URL fetching using libcurl
+if USE_CURL
+ AM_CFLAGS += -DLIBCURL
+ scepclient_LDADD += -lcurl
+endif
+
dist_man_MANS = scepclient.8
asn1.o : $(PLUTODIR)/asn1.c $(PLUTODIR)/asn1.h