summaryrefslogtreecommitdiff
path: root/src/starter/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/starter/tests/Makefile.am')
-rw-r--r--src/starter/tests/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/starter/tests/Makefile.am b/src/starter/tests/Makefile.am
new file mode 100644
index 000000000..f84327b6b
--- /dev/null
+++ b/src/starter/tests/Makefile.am
@@ -0,0 +1,19 @@
+TESTS = starter_tests
+
+check_PROGRAMS = $(TESTS)
+
+starter_tests_SOURCES = \
+ suites/test_parser.c \
+ starter_tests.h starter_tests.c
+
+starter_tests_CFLAGS = \
+ -I$(top_srcdir)/src/libstrongswan \
+ -I$(top_srcdir)/src/libstrongswan/tests \
+ -I$(top_srcdir)/src/starter \
+ @COVERAGE_CFLAGS@
+
+starter_tests_LDFLAGS = @COVERAGE_LDFLAGS@
+starter_tests_LDADD = \
+ $(top_builddir)/src/libstrongswan/libstrongswan.la \
+ $(top_builddir)/src/libstrongswan/tests/libtest.la \
+ ../libstarter.la