summaryrefslogtreecommitdiff
path: root/src/sw-collector/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/sw-collector/Makefile.am')
-rw-r--r--src/sw-collector/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/sw-collector/Makefile.am b/src/sw-collector/Makefile.am
new file mode 100644
index 000000000..4ed73c925
--- /dev/null
+++ b/src/sw-collector/Makefile.am
@@ -0,0 +1,32 @@
+sbin_PROGRAMS = sw-collector
+
+sw_collector_SOURCES = \
+ sw-collector.c \
+ sw_collector_db.h sw_collector_db.c \
+ sw_collector_dpkg.h sw_collector_dpkg.c \
+ sw_collector_history.h sw_collector_history.c \
+ sw_collector_rest_api.h sw_collector_rest_api.c
+
+sw-collector.o : $(top_builddir)/config.status
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/libstrongswan \
+ -I$(top_srcdir)/src/libtncif \
+ -I$(top_srcdir)/src/libimcv \
+ -DPLUGINS=\""random openssl sqlite curl"\"
+
+AM_CFLAGS = $(json_CFLAGS)
+
+sw_collector_LDADD = \
+ $(top_builddir)/src/libstrongswan/libstrongswan.la \
+ $(top_builddir)/src/libimcv/libimcv.la \
+ $(json_LIBS)
+
+templatesdir = $(pkgdatadir)/templates/database/sw-collector
+dist_templates_DATA = sw_collector_tables.sql
+
+man8_MANS = sw-collector.8
+
+CLEANFILES = $(man8_MANS)
+
+