summaryrefslogtreecommitdiff
path: root/rpm/walinuxagent.spec
diff options
context:
space:
mode:
authorBen Howard <ben.howard@ubuntu.com>2013-03-21 12:57:08 -0600
committerusd-importer <ubuntu-server@lists.ubuntu.com>2013-03-26 22:33:20 +0000
commit571bdcfe4b3d37c0fc94689d511712c2a0a13b69 (patch)
tree3c8b1b9ef1a85c122f210c91e7e2527533a56386 /rpm/walinuxagent.spec
parent608a9999c43d3500a13f03621c3982db505ec781 (diff)
downloadvyos-walinuxagent-571bdcfe4b3d37c0fc94689d511712c2a0a13b69.tar.gz
vyos-walinuxagent-571bdcfe4b3d37c0fc94689d511712c2a0a13b69.zip
Import patches-unapplied version 1.3.2-0ubuntu1 to ubuntu/raring-proposed
Imported using git-ubuntu import. Changelog parent: 608a9999c43d3500a13f03621c3982db505ec781 New changelog entries: * Updated to 1.3.2 as part of Windows Azure requirement (LP: #1158465). * Upstream now supports packaging; incorporated upstream packaging into Ubuntu Packaging.
Diffstat (limited to 'rpm/walinuxagent.spec')
-rw-r--r--rpm/walinuxagent.spec89
1 files changed, 89 insertions, 0 deletions
diff --git a/rpm/walinuxagent.spec b/rpm/walinuxagent.spec
new file mode 100644
index 0000000..fda355b
--- /dev/null
+++ b/rpm/walinuxagent.spec
@@ -0,0 +1,89 @@
+#===============================================================================
+# Name: WAAgent.spec
+#-------------------------------------------------------------------------------
+# Purpose : RPM Spec file for Python script packaging
+# Version : 1.2
+# Created : April 20 2012
+#===============================================================================
+
+#%define my_release 1
+
+Name: WALinuxAgent
+Summary: The Windows Azure Linux Agent
+Version: 1.3.2
+Release: 1
+License: Apache License Version 2.0
+Group: Applications/Internet
+Url: http://go.microsoft.com/fwlink/?LinkId=250998
+Source0: WALinuxAgent-1.3.2.tar.gz
+Requires: python python-pyasn1 openssh openssl util-linux sed grep sudo iptables
+Conflicts: NetworkManager
+BuildRoot: %{_tmppath}/%{name}-%{version}-build
+BuildArch: noarch
+Vendor: Microsoft Corporation
+Packager: Microsoft Corporation <walinuxagent@microsoft.com>
+
+%description
+The Windows Azure Linux Agent supports the provisioning and running of Linux VMs in the Windows Azure cloud. This package should be installed on Linux disk images that are built to run in the Windows Azure environment.
+
+%prep
+%setup
+find . -type f -exec sed -i 's/\r//' {} \;
+
+%pre -p /bin/sh
+if [ $1 = "1" ]
+then
+echo " Fresh installation of WALinuxAgent"
+elif [ $1 = "2" ]
+then
+echo " Upgrading to higher version of WALinuxAgent"
+fi
+
+%install
+mkdir -p %{buildroot}/usr/sbin
+install -m 0755 waagent %{buildroot}%{_sbindir}/
+
+%post
+chmod 755 /usr/sbin/waagent
+/usr/sbin/waagent -setup
+
+%preun -p /bin/sh
+if [ $1 = "0" ]
+then
+echo " Un-installation of WALinuxAgent"
+%{_sbindir}/waagent -uninstall
+fi
+
+%postun
+if [ $1 = "0" ]
+then
+rm -f %{_sbindir}/waagent
+fi
+
+%files
+%defattr(-,root,root)
+%{_sbindir}/waagent
+%doc LICENSE-2.0.txt
+%doc NOTICE
+%doc README
+%doc Changelog
+
+%changelog
+* Fri Feb 26 2013 - walinuxagent@microsoft.com
+- Updated version to 1.3.2 for release
+
+* Fri Feb 15 2013 - walinuxagent@microsoft.com
+- Updated version to 1.3.1 for release
+
+* Fri Jan 18 2013 - walinuxagent@microsoft.com
+- Updated version to 1.3 for release
+
+* Fri Dec 07 2012 - walinuxagent@microsoft.com
+- Updated version to 1.2 for release
+
+* Fri Nov 09 2012 - walinuxagent@microsoft.com
+- Added README and Changelog
+- Updated version to 1.1 for release
+
+* Thu May 17 2012 - walinuxagent@microsoft.com
+- Initial WALinuxAgent packages.