diff options
author | Ben Howard <ben.howard@ubuntu.com> | 2016-02-08 16:33:07 -0700 |
---|---|---|
committer | usd-importer <ubuntu-server@lists.ubuntu.com> | 2016-02-09 00:59:05 +0000 |
commit | a00729ff7421b3661e8b1a1e0fa46393379f2e96 (patch) | |
tree | 4563b927e3a57446a4a928a72a92d72c9ad4f6e6 /setup.py | |
parent | 53f54030cae2de3d5fa474a61fe51f16c7a07c79 (diff) | |
download | vyos-walinuxagent-a00729ff7421b3661e8b1a1e0fa46393379f2e96.tar.gz vyos-walinuxagent-a00729ff7421b3661e8b1a1e0fa46393379f2e96.zip |
Import patches-unapplied version 2.1.3-0ubuntu1 to ubuntu/xenial-proposed
Imported using git-ubuntu import.
Changelog parent: 53f54030cae2de3d5fa474a61fe51f16c7a07c79
New changelog entries:
* New upstream release (LP: #1543359):
- Bug fixes for extension handling
- Feature enablement for AzureStack.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -22,7 +22,7 @@ from azurelinuxagent.metadata import AGENT_NAME, AGENT_VERSION, \ AGENT_DESCRIPTION, \ DISTRO_NAME, DISTRO_VERSION, DISTRO_FULL_NAME -import azurelinuxagent.agent as agent +from azurelinuxagent.agent import Agent import setuptools from setuptools import find_packages from setuptools.command.install import install as _install @@ -72,7 +72,8 @@ def get_data_files(name, version, fullname): elif name == 'coreos': set_bin_files(data_files, dest="/usr/share/oem/bin") - set_conf_files(data_files, dest="/usr/share/oem") + set_conf_files(data_files, dest="/usr/share/oem", + src=["config/coreos/waagent.conf"]) set_logrotate_files(data_files) set_files(data_files, dest="/usr/share/oem", src="init/coreos/cloud-config.yml") @@ -149,7 +150,7 @@ class install(_install): def run(self): _install.run(self) if self.register_service: - agent.register_service() + Agent(False).register_service() setuptools.setup(name=AGENT_NAME, version=AGENT_VERSION, |