summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 5358b7e..412afa9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,11 +6,13 @@ DEB_VERSION=$(shell dpkg-parsechangelog | sed -rne 's,^Version: ([^-]+).*,\1,p')
ORIG_SRC=https://github.com/WindowsAzure/WALinuxAgent
get-packaged-orig-source:
- git clone --separate-git-dir=.git \
+ git clone --separate-git-dir=walinuxagent.checkout \
$(ORIG_SRC) orig_source
git checkout -b tags/$(DEB_VERSION)
git archive --format=tar.gz WALinuxAgent-$(DEB_VERSION) \
-o walinuxagent_$(DEB_VERSION).orig.tar.gz
+ rm -rf walinuxagent.checkout
+ rm -rf orig_source
%:
dh $@ --with python2,systemd