summaryrefslogtreecommitdiff
path: root/accel-pppd/CMakeLists.txt
diff options
context:
space:
mode:
authorDmitry Kozlov <xeb@mail.ru>2016-07-19 16:22:57 +0300
committerDmitry Kozlov <xeb@mail.ru>2016-07-19 16:22:57 +0300
commit5af337d4bd95ba001527f1a298f4594ad643f57b (patch)
tree1ed93744f622e2a2664929b1706a6e5433d4d649 /accel-pppd/CMakeLists.txt
parent1dce3168c8a43ba1ef6d2b78355933aafc35d3f9 (diff)
downloadaccel-ppp-5af337d4bd95ba001527f1a298f4594ad643f57b.tar.gz
accel-ppp-5af337d4bd95ba001527f1a298f4594ad643f57b.zip
check for setns availability
Diffstat (limited to 'accel-pppd/CMakeLists.txt')
-rw-r--r--accel-pppd/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/accel-pppd/CMakeLists.txt b/accel-pppd/CMakeLists.txt
index 70c41050..8ffcbf4d 100644
--- a/accel-pppd/CMakeLists.txt
+++ b/accel-pppd/CMakeLists.txt
@@ -50,6 +50,9 @@ ENDIF (SHAPER)
INCLUDE(CheckIncludeFile)
CHECK_INCLUDE_FILE("linux/netfilter/ipset/ip_set.h" HAVE_IPSET)
+INCLUDE(CheckFunctionExists)
+CHECK_FUNCTION_EXISTS(setns HAVE_SETNS)
+
ADD_EXECUTABLE(accel-pppd
memdebug.c
session.c