summaryrefslogtreecommitdiff
path: root/drivers/vlan_mon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/vlan_mon/CMakeLists.txt')
-rw-r--r--drivers/vlan_mon/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/drivers/vlan_mon/CMakeLists.txt b/drivers/vlan_mon/CMakeLists.txt
index 892fed16..1d0c3c88 100644
--- a/drivers/vlan_mon/CMakeLists.txt
+++ b/drivers/vlan_mon/CMakeLists.txt
@@ -14,4 +14,6 @@ ADD_CUSTOM_TARGET(vlan_mon_drv ALL
DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/driver/vlan_mon.ko
)
-INSTALL(CODE "EXECUTE_PROCESS(COMMAND make -C ${KDIR} M=${CMAKE_CURRENT_BINARY_DIR}/drivers/vlan_mon modules_install)")
+if (NOT DEFINED CPACK_TYPE)
+ INSTALL(CODE "EXECUTE_PROCESS(COMMAND make -C ${KDIR} M=${CMAKE_CURRENT_BINARY_DIR}/drivers/vlan_mon modules_install)")
+endif ()