summaryrefslogtreecommitdiff
path: root/contrib/gentoo/net-dialup/accel-ppp
diff options
context:
space:
mode:
authorDmitry Kozlov <xeb@mail.ru>2011-01-08 14:22:46 +0300
committerDmitry Kozlov <xeb@mail.ru>2011-01-08 14:22:46 +0300
commitb98f515daa345fb83002a149c1f1f33a7b4644e7 (patch)
tree89c1aeb1c047ea5c1b4be7bc1782c0d099904ef9 /contrib/gentoo/net-dialup/accel-ppp
parent53f22bd8a8cd4a407b7eb9c9b034b215e2299e30 (diff)
downloadaccel-ppp-xebd-b98f515daa345fb83002a149c1f1f33a7b4644e7.tar.gz
accel-ppp-xebd-b98f515daa345fb83002a149c1f1f33a7b4644e7.zip
updated contrib files
Diffstat (limited to 'contrib/gentoo/net-dialup/accel-ppp')
-rw-r--r--contrib/gentoo/net-dialup/accel-ppp/accel-ppp-1.1.1.ebuild80
-rw-r--r--contrib/gentoo/net-dialup/accel-ppp/accel-ppp-9999.ebuild88
-rw-r--r--contrib/gentoo/net-dialup/accel-ppp/files/accel-pppd-confd5
3 files changed, 173 insertions, 0 deletions
diff --git a/contrib/gentoo/net-dialup/accel-ppp/accel-ppp-1.1.1.ebuild b/contrib/gentoo/net-dialup/accel-ppp/accel-ppp-1.1.1.ebuild
new file mode 100644
index 0000000..8ee851f
--- /dev/null
+++ b/contrib/gentoo/net-dialup/accel-ppp/accel-ppp-1.1.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+inherit eutils linux-mod cmake-utils
+
+DESCRIPTION="PPtP/L2TP/PPPoE server for Linux"
+SRC_URI="http://sourceforge.net/projects/accel-ppp/files/accel-ppp/${P}.tar.bz2"
+HOMEPAGE="http://accel-ppp.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="~amd64 ~x86"
+IUSE="postgres debug shaper pptp_driver"
+
+DEPEND=">=sys-libs/glibc-2.8
+ dev-libs/openssl
+ dev-libs/libaio
+ shaper? ( =dev-libs/libnl-2 )
+ postgres? ( >=dev-db/postgresql-base-8.1 )"
+
+RDEPEND="$DEPEND
+ pptp_driver? ( virtual/modutils )"
+
+BUILD_TARGETS="default"
+BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+CONFIG_CHECK="PPP PPPOE"
+MODULESD_PPTP_ALIASES=("net-pf-24 pptp")
+PREFIX="/"
+MODULE_NAMES="pptp(extra:${S}/driver/)"
+
+src_prepare() {
+ sed -i -e "/mkdir/d" "${S}/accel-pppd/CMakeLists.txt"
+ sed -i -e "/INSTALL/d" "${S}/driver/CMakeLists.txt"
+}
+
+src_configure() {
+ if use debug; then
+ mycmakeargs+=( "-DCMAKE_BUILD_TYPE=Debug" )
+ fi
+
+ if use postgres; then
+ mycmakeargs+=( "-DLOG_PGSQL=TRUE" )
+ fi
+
+ if use shaper; then
+ mycmakeargs+=( "-DSHAPER=TRUE" )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use pptp_driver; then
+ cd ${S}/driver
+ linux-mod_src_compile || die "failed to build driver"
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use pptp_driver; then
+ cd ${S}/driver
+ linux-mod_src_install
+ fi
+
+ exeinto /etc/init.d
+ newexe "${S}/contrib/gentoo/net-dialup/accel-ppp/files/accel-pppd-init" accel-pppd
+
+ insinto /etc/conf.d
+ newins "${S}/contrib/gentoo/net-dialup/accel-ppp/files/pppd-confd" accel-pppd
+
+ dodir /var/log/accel-ppp
+ dodir /var/run/accel-ppp
+ dodir /var/run/radattr
+}
diff --git a/contrib/gentoo/net-dialup/accel-ppp/accel-ppp-9999.ebuild b/contrib/gentoo/net-dialup/accel-ppp/accel-ppp-9999.ebuild
new file mode 100644
index 0000000..03f2a51
--- /dev/null
+++ b/contrib/gentoo/net-dialup/accel-ppp/accel-ppp-9999.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+inherit eutils git linux-mod cmake-utils
+
+EGIT_REPO_URI="git://accel-ppp.git.sourceforge.net/gitroot/accel-ppp/accel-ppp"
+
+DESCRIPTION="PPtP/L2TP/PPPoE Server for Linux"
+SRC_URI=""
+HOMEPAGE="http://accel-ppp.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="~amd64 ~x86"
+IUSE="postgres debug shaper pptp_driver"
+
+DEPEND=">=sys-libs/glibc-2.8
+ dev-libs/openssl
+ dev-libs/libaio
+ shaper? ( =dev-libs/libnl-2 )
+ postgres? ( >=dev-db/postgresql-base-8.1 )"
+
+RDEPEND="$DEPEND
+ pptp_driver? ( virtual/modutils )"
+
+BUILD_TARGETS="default"
+BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+CONFIG_CHECK="PPP PPPOE"
+MODULESD_PPTP_ALIASES=("net-pf-24 pptp")
+PREFIX="/"
+MODULE_NAMES="pptp(extra:${S}/driver/)"
+
+src_unpack () {
+ git_src_unpack
+}
+
+src_prepare() {
+ sed -i -e "/mkdir/d" "${S}/accel-pppd/CMakeLists.txt"
+ sed -i -e "/echo/d" "${S}/accel-pppd/CMakeLists.txt"
+ sed -i -e "/INSTALL/d" "${S}/driver/CMakeLists.txt"
+}
+
+src_configure() {
+ if use debug; then
+ mycmakeargs+=( "-DCMAKE_BUILD_TYPE=Debug" )
+ fi
+
+ if use postgres; then
+ mycmakeargs+=( "-DLOG_PGSQL=TRUE" )
+ fi
+
+ if use shaper; then
+ mycmakeargs+=( "-DSHAPER=TRUE" )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use pptp_driver; then
+ cd ${S}/driver
+ #convert_to_m Makefile
+ linux-mod_src_compile || die "failed to build driver"
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use pptp_driver; then
+ cd ${S}/driver
+ linux-mod_src_install
+ fi
+
+ exeinto /etc/init.d
+ newexe "${S}/contrib/gentoo/net-dialup/accel-ppp/files/accel-pppd-init" accel-pppd
+
+ insinto /etc/conf.d
+ newins "${S}/contrib/gentoo/net-dialup/accel-ppp/files/accel-pppd-confd" accel-pppd
+
+ dodir /var/log/accel-ppp
+ dodir /var/run/accel-ppp
+ dodir /var/run/radattr
+}
diff --git a/contrib/gentoo/net-dialup/accel-ppp/files/accel-pppd-confd b/contrib/gentoo/net-dialup/accel-ppp/files/accel-pppd-confd
new file mode 100644
index 0000000..6bc0dff
--- /dev/null
+++ b/contrib/gentoo/net-dialup/accel-ppp/files/accel-pppd-confd
@@ -0,0 +1,5 @@
+# Config file for /etc/init.d/accel-pptpd
+
+# Any extra options you want to pass to pptpd
+# on start-up should be put here.
+ACCEL_PPPD_OPTS="-d -c /etc/accel-ppp.conf"