summaryrefslogtreecommitdiff
path: root/accel-pptpd/extra/CMakeLists.txt
diff options
context:
space:
mode:
authorKozlov Dmitry <dima@server>2010-12-27 18:11:42 +0300
committerKozlov Dmitry <dima@server>2010-12-27 18:11:42 +0300
commit330c5a3c8a531d79a2f87953806ef47f61262e14 (patch)
tree86270e16b44e866311b45e7a0d73409c819c8e14 /accel-pptpd/extra/CMakeLists.txt
parent453e170879f599dfe4a82f7880929a7040b8b724 (diff)
downloadaccel-ppp-330c5a3c8a531d79a2f87953806ef47f61262e14.tar.gz
accel-ppp-330c5a3c8a531d79a2f87953806ef47f61262e14.zip
updated build system
Diffstat (limited to 'accel-pptpd/extra/CMakeLists.txt')
-rw-r--r--accel-pptpd/extra/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/accel-pptpd/extra/CMakeLists.txt b/accel-pptpd/extra/CMakeLists.txt
index 282af1a..2b2d950 100644
--- a/accel-pptpd/extra/CMakeLists.txt
+++ b/accel-pptpd/extra/CMakeLists.txt
@@ -9,7 +9,10 @@ INSTALL(TARGETS pppd_compat ippool sigchld chap-secrets
IF (SHAPER)
ADD_LIBRARY(shaper_tbf SHARED shaper_tbf.c)
- TARGET_LINK_LIBRARIES(shaper_tbf nl nl-route m)
+ IF (LIBNL_PREFIX)
+ SET_PROPERTY(TARGET shaper_tbf PROPERTY COMPILE_FLAGS "-I${LIBNL_PREFIX}/include -Wl,-L${LIBNL_PREFIX}/lib")
+ ENDIF (LIBNL_PREFIX)
+ TARGET_LINK_LIBRARIES(shaper_tbf nl m)
INSTALL(TARGETS shaper_tbf LIBRARY DESTINATION lib/accel-pptp)
ENDIF (SHAPER)