summaryrefslogtreecommitdiff
path: root/accel-pptpd/extra/CMakeLists.txt
diff options
context:
space:
mode:
authorDmitry Kozlov <xeb@mail.ru>2010-10-14 00:36:11 +0400
committerDmitry Kozlov <xeb@mail.ru>2010-10-14 00:36:11 +0400
commit80e8ec99aeffcec505165f099f68d0fb2903e12b (patch)
tree099f6254aef204a781d2cd91713dddac33c4b036 /accel-pptpd/extra/CMakeLists.txt
parent07bb2569fb1dd066f07d741035960b42a07e8b73 (diff)
downloadaccel-ppp-80e8ec99aeffcec505165f099f68d0fb2903e12b.tar.gz
accel-ppp-80e8ec99aeffcec505165f099f68d0fb2903e12b.zip
extra: implemented builtin tbf shaper (using libnl-1.1)
Diffstat (limited to 'accel-pptpd/extra/CMakeLists.txt')
-rw-r--r--accel-pptpd/extra/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/accel-pptpd/extra/CMakeLists.txt b/accel-pptpd/extra/CMakeLists.txt
index a14a5a3..600c861 100644
--- a/accel-pptpd/extra/CMakeLists.txt
+++ b/accel-pptpd/extra/CMakeLists.txt
@@ -1,6 +1,8 @@
ADD_LIBRARY(pppd_compat SHARED pppd_compat.c)
ADD_LIBRARY(ippool SHARED ippool.c)
ADD_LIBRARY(sigchld SHARED sigchld.c)
+ADD_LIBRARY(shaper_tbf SHARED shaper_tbf.c)
+TARGET_LINK_LIBRARIES(shaper_tbf nl)
INSTALL(TARGETS pppd_compat ippool sigchld
LIBRARY DESTINATION usr/lib/accel-pptp