summaryrefslogtreecommitdiff
path: root/accel-pptpd/extra/CMakeLists.txt
diff options
context:
space:
mode:
authorKozlov Dmitry <dima@server>2010-10-14 14:30:53 +0400
committerKozlov Dmitry <dima@server>2010-10-14 14:30:53 +0400
commit84ff56a83a9f6b29d3300aff13ede9afc73b5a68 (patch)
tree9284cb5b797dd7d68350cd937da11cc2f579114f /accel-pptpd/extra/CMakeLists.txt
parent763fe9e3ba0faeea25cc423152a065900f901a53 (diff)
downloadaccel-ppp-84ff56a83a9f6b29d3300aff13ede9afc73b5a68.tar.gz
accel-ppp-84ff56a83a9f6b29d3300aff13ede9afc73b5a68.zip
due to libnl-1 is not thread safe, l2tp and shaper updated to use libnl-2
Diffstat (limited to 'accel-pptpd/extra/CMakeLists.txt')
-rw-r--r--accel-pptpd/extra/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/accel-pptpd/extra/CMakeLists.txt b/accel-pptpd/extra/CMakeLists.txt
index 600c861..9d58b8e 100644
--- a/accel-pptpd/extra/CMakeLists.txt
+++ b/accel-pptpd/extra/CMakeLists.txt
@@ -1,10 +1,14 @@
ADD_LIBRARY(pppd_compat SHARED pppd_compat.c)
ADD_LIBRARY(ippool SHARED ippool.c)
ADD_LIBRARY(sigchld SHARED sigchld.c)
-ADD_LIBRARY(shaper_tbf SHARED shaper_tbf.c)
-TARGET_LINK_LIBRARIES(shaper_tbf nl)
INSTALL(TARGETS pppd_compat ippool sigchld
LIBRARY DESTINATION usr/lib/accel-pptp
)
+IF (SHAPER)
+ ADD_LIBRARY(shaper_tbf SHARED shaper_tbf.c)
+ TARGET_LINK_LIBRARIES(shaper_tbf nl-route)
+ INSTALL(TARGETS shaper_tbf LIBRARY DESTINATION usr/lib/accel-pptp)
+ENDIF (SHAPER)
+