summaryrefslogtreecommitdiff
path: root/accel-pptpd/triton/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'accel-pptpd/triton/CMakeLists.txt')
-rw-r--r--accel-pptpd/triton/CMakeLists.txt40
1 files changed, 0 insertions, 40 deletions
diff --git a/accel-pptpd/triton/CMakeLists.txt b/accel-pptpd/triton/CMakeLists.txt
deleted file mode 100644
index 0c6786d..0000000
--- a/accel-pptpd/triton/CMakeLists.txt
+++ /dev/null
@@ -1,40 +0,0 @@
-SET(sources_c
- md.c
- timer.c
- triton.c
- conf_file.c
- loader.c
- log.c
- mempool.c
- event.c
-)
-
-INCLUDE(CheckFunctionExists)
-CHECK_FUNCTION_EXISTS(timerfd_create HAVE_TIMERFD)
-
-IF (HAVE_TIMERFD)
- ADD_DEFINITIONS(-DHAVE_TIMERFD)
-ELSE (HAVE_TIMERFD)
- INCLUDE (CheckCSourceCompiles)
- CHECK_C_SOURCE_COMPILES("
- #include <sys/syscall.h>
- int main()
- {
- syscall(SYS_timerfd_create);
- }" HAVE_SYSCALL)
- IF (NOT HAVE_SYSCALL)
- MESSAGE(FATAL_ERROR "Your system is too old and is not supported by accel-pptp, sorry...")
- ENDIF (NOT HAVE_SYSCALL)
- SET(sources_c ${sources_c} timerfd.c)
-ENDIF (HAVE_TIMERFD)
-
-INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
-
-ADD_DEFINITIONS(-DMODULE_PATH="${CMAKE_INSTALL_PREFIX}/lib/accel-pptp")
-
-ADD_LIBRARY(triton SHARED ${sources_c})
-TARGET_LINK_LIBRARIES(triton dl)
-
-INSTALL(TARGETS triton
- LIBRARY DESTINATION lib/accel-pptp
-)