summaryrefslogtreecommitdiff
path: root/contrib/gentoo
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/gentoo')
-rw-r--r--contrib/gentoo/net-dialup/accel-pptp/accel-pptp-1.0.ebuild62
-rw-r--r--contrib/gentoo/net-dialup/accel-pptp/accel-pptp-9999.ebuild64
-rw-r--r--contrib/gentoo/net-dialup/accel-pptp/files/options.pptp32
-rw-r--r--contrib/gentoo/net-dialup/accel-pptp/files/pptpd-confd2
-rwxr-xr-xcontrib/gentoo/net-dialup/accel-pptp/files/pptpd-init8
5 files changed, 131 insertions, 37 deletions
diff --git a/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-1.0.ebuild b/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-1.0.ebuild
new file mode 100644
index 0000000..3da1f13
--- /dev/null
+++ b/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-1.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+inherit git linux-mod cmake-utils
+
+DESCRIPTION="Point-to-Point Tunnelling Protocol Client/Server for Linux"
+SRC_URI="http://sourceforge.net/projects/accel-pptp/files/accel-pptp/${P}.tar.bz2"
+HOMEPAGE="http://accel-pptp.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="~amd64 ~x86"
+IUSE="postgres debug"
+
+DEPEND="dev-libs/openssl
+ dev-libs/libaio
+ postgres? ( >=dev-db/postgresql-base-8.1 )"
+
+RDEPEND="virtual/modutils"
+
+BUILD_TARGETS="default"
+BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+CONFIG_CHECK="PPP PPPOE"
+MODULESD_PPTP_ALIASES=("net-pf-24 pptp")
+PREFIX="/"
+
+src_prepare() {
+ sed -i -e "/mkdir/d" "${S}/accel-pptpd/CMakeLists.txt"
+ sed -i -e "/INSTALL/d" "${S}/driver/CMakeLists.txt"
+}
+
+src_configure() {
+ mycmakeargs+=( "-DBUILD_DRIVER=TRUE" )
+
+ if use debug; then
+ mycmakeargs+=( "-DCMAKE_BUILD_TYPE=Debug" )
+ fi
+
+ if use postgres; then
+ mycmakeargs+=( "-DLOG_PGSQL=TRUE" )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ MODULE_NAMES="pptp(extra:${CMAKE_BUILD_DIR}/driver/driver)"
+ linux-mod_src_install
+
+ exeinto /etc/init.d
+ newexe "${S}/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init" pptpd
+
+ insinto /etc/conf.d
+ newins "${S}/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-confd" pptpd
+
+ dodir /var/log/accel-pptp
+ dodir /var/run/radattr
+}
diff --git a/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-9999.ebuild b/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-9999.ebuild
new file mode 100644
index 0000000..4a490af
--- /dev/null
+++ b/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-9999.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+inherit git linux-mod cmake-utils
+
+EGIT_REPO_URI="git://accel-pptp.git.sourceforge.net/gitroot/accel-pptp/accel-pptp"
+
+DESCRIPTION="Point-to-Point Tunnelling Protocol Client/Server for Linux"
+SRC_URI=""
+HOMEPAGE="http://accel-pptp.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="~amd64 ~x86"
+IUSE="postgres debug"
+
+DEPEND="dev-libs/openssl
+ dev-libs/libaio
+ postgres? ( >=dev-db/postgresql-base-8.1 )"
+
+RDEPEND="virtual/modutils"
+
+BUILD_TARGETS="default"
+BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+CONFIG_CHECK="PPP PPPOE"
+MODULESD_PPTP_ALIASES=("net-pf-24 pptp")
+PREFIX="/"
+
+src_unpack() {
+ git_src_unpack
+ sed -i -e "/mkdir/d" "${S}/accel-pptpd/CMakeLists.txt"
+ sed -i -e "/INSTALL/d" "${S}/driver/CMakeLists.txt"
+}
+
+src_configure() {
+ mycmakeargs+=( "-DBUILD_DRIVER=TRUE" )
+ if use debug; then
+ mycmakeargs+=( "-DCMAKE_BUILD_TYPE=Debug" )
+ fi
+
+ if use postgres; then
+ mycmakeargs+=( "-DLOG_PGSQL=TRUE" )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ MODULE_NAMES="pptp(extra:${CMAKE_BUILD_DIR}/driver/driver)"
+ linux-mod_src_install
+
+ exeinto /etc/init.d
+ newexe "${S}/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init" pptpd
+
+ insinto /etc/conf.d
+ newins "${S}/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-confd" pptpd
+
+ dodir /var/log/accel-pptp
+ dodir /var/run/radattr
+}
diff --git a/contrib/gentoo/net-dialup/accel-pptp/files/options.pptp b/contrib/gentoo/net-dialup/accel-pptp/files/options.pptp
deleted file mode 100644
index d61ab80..0000000
--- a/contrib/gentoo/net-dialup/accel-pptp/files/options.pptp
+++ /dev/null
@@ -1,32 +0,0 @@
-#
-# Lock the port
-#
-#lock
-
-#
-# We don't need the tunnel server to authenticate itself
-#
-noauth
-
-#
-# Turn off transmission protocols we know won't be used
-#
-nobsdcomp
-nodeflate
-
-#
-# We want MPPE
-#
-require-mppe
-
-#
-# We want a sane mtu/mru
-#
-mtu 1437
-mru 1437
-
-#
-# Time this thing out of it goes poof
-#
-lcp-echo-failure 10
-lcp-echo-interval 10
diff --git a/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-confd b/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-confd
index 1169e57..fe9e088 100644
--- a/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-confd
+++ b/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-confd
@@ -2,4 +2,4 @@
# Any extra options you want to pass to pptpd
# on start-up should be put here.
-PPTPD_OPTS=""
+PPTPD_OPTS="-d -c /etc/accel-pptp.conf"
diff --git a/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init b/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init
index c053720..d8e2ee5 100755
--- a/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init
+++ b/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init
@@ -5,17 +5,17 @@ depend() {
}
start() {
- ebegin "Starting pptpd"
+ ebegin "Starting accel-pptpd"
modprobe pptp
- start-stop-daemon --start --quiet --exec /usr/sbin/pptpd -- ${PPTPD_OPTS}
+ start-stop-daemon --start --quiet --exec /usr/sbin/accel-pptpd -- -p /var/run/pptpd.pid ${PPTPD_OPTS}
eend $?
}
stop() {
- ebegin "Stopping pptpd"
+ ebegin "Stopping accel-pptpd"
start-stop-daemon --stop --quiet --pidfile /var/run/pptpd.pid
result=$?
- start-stop-daemon --stop --quiet --oknodo --exec /usr/sbin/pptpctrl
+ start-stop-daemon --stop --quiet --oknodo --exec /usr/sbin/accel-pptpd
result=$(( $result + $? ))
eend $result
}