summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Fesler <jfesler@free.gigo.com>2014-04-02 19:48:27 -0700
committerJason Fesler <jfesler@free.gigo.com>2014-04-02 19:48:27 -0700
commitcb465c6f511d63b5445a640735295de967126e2c (patch)
tree4b2e5639c92e9e659bc234b07eefcaae031b501c /configure.ac
parente8e6401f8c7bb6ab64dbbcfc10618e792fcbd85b (diff)
downloadmod_ip-cb465c6f511d63b5445a640735295de967126e2c.tar.gz
mod_ip-cb465c6f511d63b5445a640735295de967126e2c.zip
Imported without history from https://falling-sky.googlecode.com/svn/trunk/mod_ip revision 15111.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..726a7d0
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,31 @@
+AC_PREREQ([2.68])
+AC_INIT([Falling Sky mod_ip], [0.1182], [http://code.google.com/p/falling-sky/issues/list], [mod_ip], [http://code.google.com/p/falling-sky])
+AC_HEADER_RESOLV
+AC_CHECK_HEADERS([arpa/inet.h arpa/nameser.h netinet/in.h stdlib.h string.h sys/socket.h])
+AC_CHECK_FUNCS([memset strchr])
+AC_SEARCH_LIBS([res_querydomain],[resolv])
+AC_SEARCH_LIBS([__res_querydomain],[resolv])
+
+# Find a suitable apxs
+AC_ARG_WITH(apxs,
+ [ --with-apxs=PATH path to Apache apxs],
+ [
+ if test "$withval" = "yes"; then
+ AC_CHECK_PROGS(APXS, apxs2 apxs /opt/local/apache2/bin/apxs /usr/local/bin/apxs, reject)
+ else
+ APXS=$withval
+ AC_SUBST(APXS)
+ fi
+ ],
+ [
+ AC_CHECK_PROGS(APXS, apxs2 apxs /opt/local/apache2/bin/apxs /usr/local/bin/apachectl, reject)
+ ])
+if test "$APXS" = "reject"; then
+ AC_MSG_ERROR([Could not find apxs on the path.])
+fi
+
+
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT
+