summaryrefslogtreecommitdiff
path: root/packages/bddeb
diff options
context:
space:
mode:
authorScott Moser <smoser@ubuntu.com>2012-07-06 17:03:11 -0400
committerScott Moser <smoser@ubuntu.com>2012-07-06 17:03:11 -0400
commit95711130af22f1d597aa0ab6b5a39d0af16f8a28 (patch)
treed52695b9ef1c4523190ae0dfe4ba5c707073c593 /packages/bddeb
parent048b0953b4f33e6fe4f748ddddb392b6667c4f3b (diff)
downloadvyos-cloud-init-95711130af22f1d597aa0ab6b5a39d0af16f8a28.tar.gz
vyos-cloud-init-95711130af22f1d597aa0ab6b5a39d0af16f8a28.zip
setup.py: rename "daemon type" to "init system"
This brings with it other changes, and also makes an install install all of the requisite init files. (ie, cloud-init needs the -local and the non-local)
Diffstat (limited to 'packages/bddeb')
-rwxr-xr-xpackages/bddeb4
1 files changed, 2 insertions, 2 deletions
diff --git a/packages/bddeb b/packages/bddeb
index b5a70dd8..10ad08b3 100755
--- a/packages/bddeb
+++ b/packages/bddeb
@@ -29,7 +29,7 @@ PKG_MP = {
}
-def write_debian_folder(root, version, revno, daemon_type):
+def write_debian_folder(root, version, revno, init_sys):
deb_dir = util.abs_join(root, 'debian')
os.makedirs(deb_dir)
@@ -67,7 +67,7 @@ def write_debian_folder(root, version, revno, daemon_type):
templater.render_to_file(util.abs_join('debian', 'rules'),
util.abs_join(deb_dir, 'rules'),
- params={'daemon_type': daemon_type})
+ params={'init_sys': init_sys})
# Just copy the following directly
for base_fn in ['dirs', 'copyright', 'compat', 'pycompat']: