summaryrefslogtreecommitdiff
path: root/packages/brpm
diff options
context:
space:
mode:
authorJoshua Harlow <harlowja@yahoo-inc.com>2014-11-25 11:54:51 -0800
committerJoshua Harlow <harlowja@yahoo-inc.com>2014-11-25 11:54:51 -0800
commit26af82a55325c460fdeb7eb6dceef7d433671e47 (patch)
treea7b2e972073d2de223b1bef7519f3122bef549d2 /packages/brpm
parent1db41a6f5283d38dff6de0b0421d51eac869a39c (diff)
parent7b39b3976f94fd9ce9cbe39324ec14ad5a7c334e (diff)
downloadvyos-cloud-init-26af82a55325c460fdeb7eb6dceef7d433671e47.tar.gz
vyos-cloud-init-26af82a55325c460fdeb7eb6dceef7d433671e47.zip
Fixes rpm spec file build issues (its not currently building).
Currently the rpm building process that cloud-init provides is not working correctly. This adjusts the spec file, the setup.py file and the distro files to ensure that it continues to work as expected.
Diffstat (limited to 'packages/brpm')
-rwxr-xr-xpackages/brpm1
1 files changed, 1 insertions, 0 deletions
diff --git a/packages/brpm b/packages/brpm
index b8bbff9d..9657b1dd 100755
--- a/packages/brpm
+++ b/packages/brpm
@@ -244,6 +244,7 @@ def main():
spec_fn = util.abs_join(root_dir, 'cloud-init.spec')
util.write_file(spec_fn, contents)
print("Created spec file at %r" % (spec_fn))
+ print(contents)
for p in args.patches:
util.copy(p, util.abs_join(arc_dir, os.path.basename(p)))