summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorHåkon Nessjøen <haakon.nessjoen@gmail.com>2010-11-01 23:06:26 +0100
committerHåkon Nessjøen <haakon.nessjoen@gmail.com>2010-11-01 23:06:26 +0100
commit50d04396d84bcf0adf1b44223c4d751562639225 (patch)
treedbf9f18afbbcbcafcd29184441a77fc4b45b6cf7 /debian
parentf241a46d9901f6c6c679838b35c90cc3619167be (diff)
downloadMAC-Telnet-50d04396d84bcf0adf1b44223c4d751562639225.tar.gz
MAC-Telnet-50d04396d84bcf0adf1b44223c4d751562639225.zip
Removed dependency of libssl/crypto. Added L. Peter Deutsch's implementation of MD5 instead.
Diffstat (limited to 'debian')
-rw-r--r--debian/README22
-rw-r--r--debian/changelog5
-rw-r--r--debian/control4
3 files changed, 23 insertions, 8 deletions
diff --git a/debian/README b/debian/README
index f6c0e51..3dc7f0e 100644
--- a/debian/README
+++ b/debian/README
@@ -4,16 +4,11 @@ MAC-Telnet for Linux
A linux console tool for connecting to MikroTik RouterOS devices via their
ethernet address.
-NB: Alpha stage code. Do not expect to run flawlessy.
+NB: Beta stage code. Do not expect to run flawlessy.
Installation
------------
-Make sure you have installed openssl development files.
-
-For Ubuntu users:
- sudo apt-get install libssl-dev
-
Then download source tarball, extract, compile and install:
wget http://github.com/haakonnessjoen/MAC-Telnet/tarball/master
@@ -26,6 +21,21 @@ Now you're ready.
Usage
-----
+ # mactelnet -h
+ Usage: ./mactelnet <ifname> <MAC|identity> [-h] [-n] [-u <username>] [-p <password>]
+
+ Parameters:
+ ifname Network interface that the RouterOS resides on. (example: eth0)
+ MAC MAC-Address of the RouterOS device. Use mndp to discover them.
+ identity The identity/name of your RouterOS device. Uses MNDP protocol to find it..
+ -n Do not use broadcast packets. Less insecure but requires root privileges.
+ -u Specify username on command line.
+ -p Specify password on command line.
+ -h This help.
+
+
+ Example:
+
$ ./mactelnet eth0 0:c:42:43:58:a5 -u admin
Password:
Connecting to 0:c:42:43:58:a5...done
diff --git a/debian/changelog b/debian/changelog
index 9b3ecfe..57c442f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,8 @@
+mactelnet (0.1-1ubuntu1) unstable; urgency=low
+
+ * Removed libssl dependency
+
+ -- Haakon Nessjoen <haakon.nessjoen@gmail.com> Mon, 01 Nov 2010 23:01:49 +0200
mactelnet (0.1-0ubuntu1) unstable; urgency=low
* Initial Release.
diff --git a/debian/control b/debian/control
index 04cf8f5..9cac6cb 100644
--- a/debian/control
+++ b/debian/control
@@ -2,13 +2,13 @@ Source: mactelnet
Section: net
Priority: extra
Maintainer: Haakon Nessjoen <haakon.nessjoen@gmail.com>
-Build-Depends: debhelper (>= 7), linux-libc-dev (>= 2.6), libssl-dev (>= 0.9.8g-9)
+Build-Depends: debhelper (>= 7), linux-libc-dev (>= 2.6)
Standards-Version: 3.8.0
Homepage: http://github.com/haakonnessjoen/MAC-Telnet/
Package: mactelnet
Architecture: any
-Depends: libssl0.9.8 (>= 0.9.8g-9), libc6 (>= 2.9)
+Depends: libc6 (>= 2.9)
Description: MAC-Telnet client for Linux
A linux console tool for connecting to MikroTik RouterOS devices via their ethernet address.