summaryrefslogtreecommitdiff
path: root/zerotier-one.spec
diff options
context:
space:
mode:
authorAdam Ierymenko <adam.ierymenko@gmail.com>2016-06-25 14:04:08 -0700
committerAdam Ierymenko <adam.ierymenko@gmail.com>2016-06-25 14:04:08 -0700
commitaf0a2055946dedb32d66311cd6518522d9acae03 (patch)
treead7a8f96e85d5074f0e18ebe8ebf2d7aef66b3f6 /zerotier-one.spec
parent06e2e8119e9167ea85bd9fd5c023fa48db1b8c12 (diff)
downloadinfinitytier-af0a2055946dedb32d66311cd6518522d9acae03.tar.gz
infinitytier-af0a2055946dedb32d66311cd6518522d9acae03.zip
Build and spec file updates for CentOS6
Diffstat (limited to 'zerotier-one.spec')
-rw-r--r--zerotier-one.spec82
1 files changed, 78 insertions, 4 deletions
diff --git a/zerotier-one.spec b/zerotier-one.spec
index 845a02bb..77d0c6bf 100644
--- a/zerotier-one.spec
+++ b/zerotier-one.spec
@@ -1,6 +1,6 @@
Name: zerotier-one
-Version: 1.1.5
-Release: 0.3%{?dist}
+Version: 1.1.6
+Release: 0.1%{?dist}
Summary: ZeroTier One network virtualization service
License: GPLv3
@@ -10,17 +10,32 @@ Source0: %{name}-%{version}.tar.gz
BuildRequires: http-parser-devel
BuildRequires: lz4-devel
BuildRequires: libnatpmp-devel
+
+%if 0%{rhel} > 7
+BuildRequires: libnatpmp-devel
BuildRequires: systemd
+%endif
+
%if 0%{?fedora} >= 21
+BuildRequires: systemd
BuildRequires: json-parser-devel
%endif
Requires: http-parser
Requires: lz4
Requires: libnatpmp
+
+%if 0%{rhel} >= 7
Requires: systemd
+%endif
+
+%if 0%{rhel} <= 6
+Requires: chkconfig
+%endif
+
%if 0%{?fedora} >= 21
-BuildRequires: json-parser
+Requires: systemd
+Requires: json-parser
%endif
Provides: bundled(miniupnpc) = 2.0
@@ -54,28 +69,87 @@ make ZT_USE_MINIUPNPC=1 %{?_smp_mflags}
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
+%if 0%{rhel} >= 7
+mkdir -p $RPM_BUILD_ROOT%{_unitdir}
+cp debian/zerotier-one.service $RPM_BUILD_ROOT%{_unitdir}/%{name}.service
+%endif
+%if 0%{fedora} >= 21
mkdir -p $RPM_BUILD_ROOT%{_unitdir}
cp debian/zerotier-one.service $RPM_BUILD_ROOT%{_unitdir}/%{name}.service
+%endif
+%if 0%{rhel} <= 6
+cp ext/installfiles/linux/zerotier-one.init.rhel6 $RPM_BUILD_ROOT/etc/init.d/zerotier-one
+chmod 0755 $RPM_BUILD_ROOT/etc/init.d/zerotier-one
+%endif
%files
%{_sbindir}/*
%{_bindir}/*
%{_mandir}/*
%{_localstatedir}/*
+%if 0%{rhel} >= 7
%{_unitdir}/%{name}.service
+%endif
+%if 0%{fedora} >= 21
+%{_unitdir}/%{name}.service
+%endif
+%if 0%{rhel} <= 6
+/etc/init.d/zerotier-one
+%endif
%doc AUTHORS.md README.md
%license LICENSE.GPL-3
%post
+%if 0%{rhel} >= 7
%systemd_post zerotier-one.service
+%endif
+%if 0%{fedora} >= 21
+%systemd_post zerotier-one.service
+%endif
+%if 0%{rhel} <= 6
+case "$1" in
+ 1)
+ chkconfig --add zerotier-one
+ ;;
+ 2)
+ chkconfig --del newservice
+ chkconfig --add newservice
+ ;;
+esac
+%endif
%preun
+%if 0%{rhel} >= 7
%systemd_preun zerotier-one.service
+%endif
+%if 0%{fedora} >= 21
+%systemd_preun zerotier-one.service
+%endif
+%if 0%{rhel} <= 6
+case "$1" in
+ 0)
+ service zerotier-one stop
+ chkconfig --del zerotier-one
+ ;;
+ 1)
+ # This is an upgrade.
+ :
+ ;;
+esac
+%endif
%postun
+%if 0%{rhel} >= 7
%systemd_postun_with_restart zerotier-one.service
+%endif
+%if 0%{fedora} >= 21
+%systemd_postun_with_restart zerotier-one.service
+%endif
%changelog
+* Sat Jun 25 2016 Adam Ierymenko <adam.ierymenko@zerotier.com> - 1.1.6-0.1
+- now builds on CentOS 6 as well as newer distros, and some cleanup
+
* Wed Jun 08 2016 François Kooman <fkooman@tuxed.net> - 1.1.5-0.3
- include systemd unit file
@@ -83,4 +157,4 @@ cp debian/zerotier-one.service $RPM_BUILD_ROOT%{_unitdir}/%{name}.service
- add libnatpmp as (build)dependency
* Wed Jun 08 2016 François Kooman <fkooman@tuxed.net> - 1.1.5-0.1
-- initial package \ No newline at end of file
+- initial package