summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules7
3 files changed, 11 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 668dbbfd..145b4d6a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,5 @@
zerotier-one (1.1.5) UNRELEASED; urgency=medium
- * Initial release. (Closes: #XXXXXX)
+ * Development package -- first clean Debian packaging test.
- -- root <root@linux-mercury-debian> Wed, 08 Jun 2016 10:05:01 -0700
+ -- Adam Ierymenko <adam.ierymenko@zerotier.com> Wed, 08 Jun 2016 10:05:01 -0700
diff --git a/debian/control b/debian/control
index 191ae775..05689c5a 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,8 @@ Homepage: https://www.zerotier.com/
Package: zerotier-one
Architecture: any
-Depends: libhttp-parser2.1, liblz4-1, libnatpmp1
+Depends: ${shlibs:Depends}, libhttp-parser2.1, liblz4-1, libnatpmp1
+Homepage: https://www.zerotier.com/
Description: ZeroTier network virtualization service
ZeroTier One lets you join ZeroTier virtual networks and
have them appear as tun/tap ports on your system. See
diff --git a/debian/rules b/debian/rules
index cbe925d7..6ccd039d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,3 +1,10 @@
#!/usr/bin/make -f
+
+CFLAGS=-O3 -fstack-protector-strong
+CXXFLAGS=-O3 -fstack-protector-strong
+
%:
dh $@
+
+override_dh_auto_build:
+ make ZT_USE_MINIUPNPC=1 -j 2