summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog24
-rw-r--r--debian/control4
-rw-r--r--debian/control.wheezy4
-rw-r--r--debian/postinst9
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/rules.static16
-rwxr-xr-xdebian/rules.wheezy2
-rw-r--r--debian/rules.wheezy.static11
-rw-r--r--debian/source/format (renamed from debian/format)0
9 files changed, 66 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index aa2fb534..b13e179a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,27 @@
+zerotier-one (1.2.6) unstable; urgency=medium
+
+ * See https://github.com/zerotier/ZeroTierOne for release notes.
+
+ -- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 17 Apr 2018 01:00:00 -0700
+
+zerotier-one (1.2.4) unstable; urgency=medium
+
+ * See https://github.com/zerotier/ZeroTierOne for release notes.
+
+ -- Adam Ierymenko <adam.ierymenko@zerotier.com> Mon, 24 Mar 2017 01:00:00 -0700
+
+zerotier-one (1.2.2) unstable; urgency=medium
+
+ * See https://github.com/zerotier/ZeroTierOne for release notes.
+
+ -- Adam Ierymenko <adam.ierymenko@zerotier.com> Fri, 17 Mar 2017 01:00:00 -0700
+
+zerotier-one (1.2.0) unstable; urgency=medium
+
+ * See https://github.com/zerotier/ZeroTierOne for release notes.
+
+ -- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 14 Mar 2017 09:08:00 -0700
+
zerotier-one (1.1.14) unstable; urgency=medium
* See https://github.com/zerotier/ZeroTierOne for release notes.
diff --git a/debian/control b/debian/control
index 46b8307f..a9554f19 100644
--- a/debian/control
+++ b/debian/control
@@ -3,14 +3,14 @@ Maintainer: Adam Ierymenko <adam.ierymenko@zerotier.com>
Section: net
Priority: optional
Standards-Version: 3.9.6
-Build-Depends: debhelper (>= 9), liblz4-dev, libnatpmp-dev, dh-systemd, ruby-ronn
+Build-Depends: debhelper (>= 9), dh-systemd
Vcs-Git: git://github.com/zerotier/ZeroTierOne
Vcs-Browser: https://github.com/zerotier/ZeroTierOne
Homepage: https://www.zerotier.com/
Package: zerotier-one
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, liblz4-1, libnatpmp1, iproute2
+Depends: ${shlibs:Depends}, ${misc:Depends}, iproute2, adduser, libstdc++6
Homepage: https://www.zerotier.com/
Description: ZeroTier network virtualization service
ZeroTier One lets you join ZeroTier virtual networks and
diff --git a/debian/control.wheezy b/debian/control.wheezy
index 0cbd151b..f14c8760 100644
--- a/debian/control.wheezy
+++ b/debian/control.wheezy
@@ -3,14 +3,14 @@ Maintainer: Adam Ierymenko <adam.ierymenko@zerotier.com>
Section: net
Priority: optional
Standards-Version: 3.9.4
-Build-Depends: debhelper (>= 9), ruby-ronn
+Build-Depends: debhelper (>= 9)
Vcs-Git: git://github.com/zerotier/ZeroTierOne
Vcs-Browser: https://github.com/zerotier/ZeroTierOne
Homepage: https://www.zerotier.com/
Package: zerotier-one
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, iproute
+Depends: ${shlibs:Depends}, ${misc:Depends}, iproute, libstdc++6
Homepage: https://www.zerotier.com/
Description: ZeroTier network virtualization service
ZeroTier One lets you join ZeroTier virtual networks and
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 00000000..ecd148a4
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,9 @@
+#!/bin/sh -e
+
+case "$1" in
+ configure)
+ adduser --system --group --home /var/lib/zerotier-one --no-create-home zerotier-one
+ ;;
+esac
+
+#DEBHELPER#
diff --git a/debian/rules b/debian/rules
index cf0b04ff..e6644d8e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,7 +7,7 @@ CXXFLAGS=-O3 -fstack-protector-strong
dh $@ --with systemd
override_dh_auto_build:
- make ZT_USE_MINIUPNPC=1 -j 2
+ make -j 4
override_dh_systemd_start:
dh_systemd_start --restart-after-upgrade
diff --git a/debian/rules.static b/debian/rules.static
new file mode 100644
index 00000000..72c52955
--- /dev/null
+++ b/debian/rules.static
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+CFLAGS=-O3 -fstack-protector-strong
+CXXFLAGS=-O3 -fstack-protector-strong
+
+%:
+ dh $@ --with systemd
+
+override_dh_auto_build:
+# make -j 2
+
+override_dh_systemd_start:
+ dh_systemd_start --restart-after-upgrade
+
+override_dh_installinit:
+ dh_installinit --name=zerotier-one -- defaults
diff --git a/debian/rules.wheezy b/debian/rules.wheezy
index e51d794e..55e2647a 100755
--- a/debian/rules.wheezy
+++ b/debian/rules.wheezy
@@ -7,5 +7,5 @@ CXXFLAGS=-O3 -fstack-protector
dh $@
override_dh_auto_build:
- make ZT_USE_MINIUPNPC=1 -j 2
+ make -j 2
diff --git a/debian/rules.wheezy.static b/debian/rules.wheezy.static
new file mode 100644
index 00000000..0165be37
--- /dev/null
+++ b/debian/rules.wheezy.static
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+CFLAGS=-O3 -fstack-protector
+CXXFLAGS=-O3 -fstack-protector
+
+%:
+ dh $@
+
+override_dh_auto_build:
+# make -j 2
+
diff --git a/debian/format b/debian/source/format
index 46ebe026..46ebe026 100644
--- a/debian/format
+++ b/debian/source/format