summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDave Olson <olson@cumulusnetworks.com>2017-06-16 15:49:56 -0700
committerDave Olson <olson@cumulusnetworks.com>2017-06-16 16:18:07 -0700
commit3a47df99b207d85469d0a3126aacf491ba61c1d4 (patch)
treeb32ecb55edf4e2712bb3f0877a875b4477acbb4b /debian/rules
parenta11bbaeb6b0635dd852fb511a28f67da80327fef (diff)
downloadlibpam-radius-auth-3a47df99b207d85469d0a3126aacf491ba61c1d4.tar.gz
libpam-radius-auth-3a47df99b207d85469d0a3126aacf491ba61c1d4.zip
Added debian directory from jessie 1.3.16, with changelog updates
Cleaned up to use simpler rules file as part of that import. Also newer compat level, etc.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4e68084
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
+# -Wnostrict-aliasing for md5.c
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+CFLAGS+=-g3 -Wno-strict-aliasing -DCONF_FILE=\"/etc/pam_radius_auth.conf\"
+
+ifeq ($(DEB_HOST_GNU_CPU),(hppa|m68k|mips|powerpc|s390|sparc|sparc64|sheb))
+ CFLAGS += -DHIGHFIRST
+endif
+export CFLAGS
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ ./configure
+