summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJeroen Nijhof <jeroenn@saralt0078.(none)>2010-12-22 11:12:08 +0100
committerJeroen Nijhof <jeroenn@saralt0078.(none)>2010-12-22 11:12:08 +0100
commit4e0f4aa68e082b469663e3ebc8ec83c9400dab4b (patch)
tree08d50b522bc250659704b2dfc73d887979198fd4 /debian
downloadpam_tacplus-4e0f4aa68e082b469663e3ebc8ec83c9400dab4b.tar.gz
pam_tacplus-4e0f4aa68e082b469663e3ebc8ec83c9400dab4b.zip
Initial commit
Diffstat (limited to 'debian')
-rw-r--r--debian/README.Debian18
-rw-r--r--debian/changelog6
-rw-r--r--debian/control16
-rw-r--r--debian/copyright27
-rw-r--r--debian/libpam-tacplus.dirs1
-rw-r--r--debian/libpam-tacplus.docs2
-rwxr-xr-xdebian/rules93
7 files changed, 163 insertions, 0 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..c4f1b6c
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,18 @@
+pam_tacplus for Debian
+---------------------
+
+The pam_tacplus module is placed in /lib/security/
+to include pam_tacplus.so edit /etc/pam.d/common-*
+
+Run script -c "dpkg-buildpackage" as root
+in the source directory above this one.
+
+You will need at least the debhelper and libpam0g-dev
+packages.
+
+Look at the content list of the deb file with "dpkg -c"
+
+Change the version number by running "debchange -i" and add in the NEWS
+entries for the given version.
+
+ -- J. Nijhof <jeroen@nijhofnet.nl>, Sun, 14 Feb 2010
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..5a5ad19
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+libpam-tacplus (1.3.1-1) unstable; urgency=low
+
+ * First version of pam_tacplus debian package
+
+ -- Jeroen Nijhof <jeroen@nijhofnet.nl> Sun, 14 Feb 2010 23:07:00 +0100
+
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..846b7ce
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: libpam-tacplus
+Priority: optional
+Maintainer: J. Nijhof <jeroen@nijhofnet.nl>
+Build-Depends: debhelper (>= 4.0.0), libpam-dev, chrpath
+Standards-Version: 1.3.1
+Section: libs
+
+Package: libpam-tacplus
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Suggests: libpam-doc
+Description: TACACS+ protocol client library and PAM module in C.
+ This PAM module support authentication, authorization (account management) and
+ accounting (session management) performed using TACACS+ protocol designed by Cisco.
+
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..f5a1d76
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,27 @@
+
+pam-tacplus
+
+ Copyright (C) 2010, Pawel Krawczyk <kravietz@ceti.com.pl>
+ and Jeroen Nijhof <jeroen@nijhofnet.nl>.
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
+ MA 02110-1301, USA.
+
+All the other scripts and control files for building and installing
+libpam-tacplus under Debian GNU/Linux are also under the GNU General Public
+License (GPL) version 2 or later.
+
+On Debian GNU/Linux systems, the complete text of the GNU General
+Public License can be found in '/usr/share/common-licenses/GPL'.
+
diff --git a/debian/libpam-tacplus.dirs b/debian/libpam-tacplus.dirs
new file mode 100644
index 0000000..d1f6515
--- /dev/null
+++ b/debian/libpam-tacplus.dirs
@@ -0,0 +1 @@
+lib/security
diff --git a/debian/libpam-tacplus.docs b/debian/libpam-tacplus.docs
new file mode 100644
index 0000000..f1b7621
--- /dev/null
+++ b/debian/libpam-tacplus.docs
@@ -0,0 +1,2 @@
+README
+sample.pam
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a7fba46
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,93 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+# Debhelper compatibility
+export DH_COMPAT=5
+
+# Do not include CVS/svn source directories
+export DH_ALWAYS_EXCLUDE=CVS:.svn
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+DEBFLAGS=
+ifeq ($(DEB_HOST_ARCH),i386)
+ DEBFLAGS = -m32
+endif
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+
+ # Add here commands to compile the package.
+ DEBFLAGS=$(DEBFLAGS) $(MAKE)
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ # Add here commands to clean up after the build process.
+ $(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean
+ dh_installdirs
+
+ # Add here commands to install the package into debian/libpam-tacplus
+ cp pam_tacplus.so $(CURDIR)/debian/libpam-tacplus/lib/security/
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs CHANGES
+ dh_installdocs
+# dh_installexamples
+# dh_install
+# dh_movefiles --sourcedir=debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+# dh_installman
+# dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install