summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2009-01-30 12:16:54 -0800
committerStephen Hemminger <stephen.hemminger@vyatta.com>2009-01-30 13:13:46 -0800
commita4a2575ccf7057ad77ab02a5486a1e7145504ac8 (patch)
treedf8cf3c2cd2527b2212223a6abc770519e1f18d1 /Makefile.am
parentaa8ecb694dc85cb67e2c9f7b5fe911888d0310e4 (diff)
downloadvyatta-cfg-qos-a4a2575ccf7057ad77ab02a5486a1e7145504ac8.tar.gz
vyatta-cfg-qos-a4a2575ccf7057ad77ab02a5486a1e7145504ac8.zip
Fix QoS over ppp interfaces
Bug 3473 Add ppp startup script to apply QoS on start of related interfaces.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 950d05f..f9d1d10 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,10 +12,14 @@ share_perl5_DATA += lib/Vyatta/Qos/RateLimiter.pm
share_perl5_DATA += lib/Vyatta/Qos/DropTail.pm
share_perl5_DATA += lib/Vyatta/Qos/TrafficLimiter.pm
+etcdir = /etc
+etc_SCRIPTS =
+
cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
cpio -0pd
install-exec-hook:
mkdir -p $(DESTDIR)$(cfgdir)
+ mkdir -p $(DESTDIR)/etc/ppp/ip-up.d
cd templates; $(cpiop) $(DESTDIR)$(cfgdir)