summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Southworth <john.southworth@vyatta.com>2012-09-04 16:36:24 -0700
committerJohn Southworth <john.southworth@vyatta.com>2012-09-04 16:36:24 -0700
commit918bd40d3e3f238a800b1486f70e2d5ee1d71a72 (patch)
tree38763bbaf267d6a5ecf0dbd417628dce5c92a18e /Makefile.am
parent8faaec7b1b9bd034449348b693c5216e349a04ec (diff)
downloadvyatta-cfg-system-918bd40d3e3f238a800b1486f70e2d5ee1d71a72.tar.gz
vyatta-cfg-system-918bd40d3e3f238a800b1486f70e2d5ee1d71a72.zip
Bugfix 8290
Don't allow default password to persist after first boot. Due to the numerous ways a user can get a vyatta system this required a lot of changes. 1. Don't allow a user to set a password to 'vyatta' after first login, but allow it on the initial boot otherwise the system will have no user. 2. Don't allow the password to be set to vyatta in installer. 3. Force password change on first login. under the following conditions: 3.a. User is an admin level user. Operators do not have the abillity to change the config so they can't change passwords. Allow 'vyatta' to be the password until an admin logs in. 3.b. This is not the livecd, its silly to force a password change before install.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f654541c..0d2f049d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,7 @@ bin_sudo_usersdir = $(bindir)/sudo-users
curverdir = $(sysconfdir)/config-migrate/current
checkparamsonrebootdir = $(bindir)/sudo-users/check-params-on-reboot.d
initddir = /etc/init.d
+profiledir = /etc/profile.d
netplugupdir = /etc/netplug/linkup.d
netplugdowndir = /etc/netplug/linkdown.d
modprobedir = /etc/modprobe.d
@@ -13,6 +14,7 @@ bin_SCRIPTS =
sbin_SCRIPTS =
sysconf_DATA =
initd_SCRIPTS =
+profile_SCRIPTS =
checkparamsonreboot_SCRIPTS =
checkparamsonreboot_DATA =
@@ -21,13 +23,15 @@ checkparamsonreboot_DATA += scripts/check-params-on-reboot.d/README
initd_SCRIPTS += etc/init.d/vyatta-config-reboot-params
checkparamsonreboot_SCRIPTS += scripts/check-params-on-reboot.d/ipv6_disable_blacklist
+profile_SCRIPTS += etc/profile.d/vyatta-login.sh
+
netplugup_SCRIPTS = scripts/netplug/linkup/dhclient
netplugdown_SCRIPTS = scripts/netplug/linkdown/dhclient
bin_SCRIPTS += scripts/progress-indicator
bin_SCRIPTS += scripts/vyatta-functions
-
+sbin_SCRIPTS += scripts/vyatta-first-login-passwd.sh
sbin_SCRIPTS += scripts/check_file_in_config_dir
sbin_SCRIPTS += scripts/init-floppy
sbin_SCRIPTS += scripts/rl-system.init