summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/vyatta-cfg-system.postinst.in6
2 files changed, 12 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index e07f7fa7..b42ad1fe 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vyatta-cfg-system (0.15.48+jenner44) unstable; urgency=low
+
+ * Fix 4748: Pre-login message files (/etc/issue,/etc/issue.net) are
+
+ -- Stig Thormodsrud <stig@vyatta.com> Thu, 30 Jul 2009 13:43:58 -0700
+
vyatta-cfg-system (0.15.48+jenner43) unstable; urgency=low
* fix undefined array ref
diff --git a/debian/vyatta-cfg-system.postinst.in b/debian/vyatta-cfg-system.postinst.in
index 38757106..a44fe657 100644
--- a/debian/vyatta-cfg-system.postinst.in
+++ b/debian/vyatta-cfg-system.postinst.in
@@ -109,6 +109,12 @@ EOF
# purge off ancient devfs stuff from /etc/securetty
cp $sysconfdir/securetty /etc/securetty
+
+ for f in issue issue.net; do
+ if [ ! -e /etc/$f.old ]; then
+ cp $sysconfdir/$f /etc/$f
+ fi
+ done
fi
# update crontab for logrotate