summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorbradsoto <1541011+bradsoto@users.noreply.github.com>2020-01-22 12:39:39 -0700
committerChristian Poessinger <christian@poessinger.com>2020-01-22 20:39:39 +0100
commit699963ac8cce88fe15751e3b426f4381bade02f2 (patch)
treebdd845e0d3028aac81616f042b29affc16f2c627 /Makefile.am
parent4e3cfa90c427f173be7e295916911de70b40efd7 (diff)
downloadvyatta-cfg-699963ac8cce88fe15751e3b426f4381bade02f2.tar.gz
vyatta-cfg-699963ac8cce88fe15751e3b426f4381bade02f2.zip
Makefile: define BUILT_SOURCES variable to support concurret builds
When running make -jN, make would fail randomly with higher numbers of N. "cli_parse.h not found". This fixes the error.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index affc413..010e0b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,6 +75,7 @@ src_libvyatta_cfg_la_SOURCES += src/commit/commit-algorithm.cpp
CLEANFILES = src/cli_parse.c src/cli_parse.h src/cli_def.c src/cli_val.c
CLEANFILES += src/cparse/cparse.cpp src/cparse/cparse.h
CLEANFILES += src/cparse/cparse_lex.c
+BUILT_SOURCES = src/cli_parse.h src/cli_def.c src/cli_val.c
LDADD = src/libvyatta-cfg.la
LDADD += $(GOBJECT_LIBS)