summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Davidson <james.davidson@vyatta.com>2012-10-19 12:11:03 -0700
committerJames Davidson <james.davidson@vyatta.com>2012-10-19 13:47:02 -0700
commit5ffad3ec21332a7cd8b967231b84d5eecee5be92 (patch)
treec89335c695e4608fe38d6110138549058c89720c /configure.ac
parent72c915729c7d98a23db8415119283808110d0972 (diff)
downloadvyatta-cfg-5ffad3ec21332a7cd8b967231b84d5eecee5be92.tar.gz
vyatta-cfg-5ffad3ec21332a7cd8b967231b84d5eecee5be92.zip
Add support for overlayfs and start using it
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 04210fd..088461a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,12 @@ AC_ARG_ENABLE([nostrip],
[include -nostrip option during packaging]),
[NOSTRIP=-nostrip], [NOSTRIP=])
+AC_ARG_ENABLE([overlayfs],
+ AC_HELP_STRING([--enable-overlayfs],
+ [use overlayfs instead of unionfs (default is no)]),
+ [enable_overlayfs=yes], [enable_overlayfs=no])
+AM_CONDITIONAL([USE_OVERLAYFS], [test "$enable_overlayfs" != no])
+
AC_CONFIG_FILES(
[Makefile]
[perl_dmod/Makefile]