summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAn-Cheng Huang <ancheng@vyatta.com>2010-07-28 14:30:32 -0700
committerAn-Cheng Huang <ancheng@vyatta.com>2010-07-28 14:30:32 -0700
commit639c835bc2730a4fbffd915f5b2028a68375ee7a (patch)
tree203d61e1d5e8ef422d6aba3851d2f83a1f838b6b /debian/rules
parent0247864ef578ac05bbac8dc5175e674ce7b82714 (diff)
downloadvyatta-cfg-639c835bc2730a4fbffd915f5b2028a68375ee7a.tar.gz
vyatta-cfg-639c835bc2730a4fbffd915f5b2028a68375ee7a.zip
add new cstore library
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules125
1 files changed, 31 insertions, 94 deletions
diff --git a/debian/rules b/debian/rules
index 6b9bdf7..e5353c9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,108 +1,45 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# Use hardening options (in future)
+## uncomment to enable hardening
#export DEB_BUILD_HARDENING=1
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-PACKAGE=vyatta-cfg
-PKGDIR=$(CURDIR)/debian/$(PACKAGE)
-
-CFLAGS = -Wall -g
-
-configure = ./configure
-configure += --host=$(DEB_HOST_GNU_TYPE)
-configure += --build=$(DEB_BUILD_GNU_TYPE)
-configure += --prefix=/opt/vyatta
-configure += --mandir=\$${prefix}/share/man
-configure += --infodir=\$${prefix}/share/info
-configure += CFLAGS="$(CFLAGS)"
-configure += LDFLAGS="-Wl,-z,defs"
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -Os
-endif
-
-configure: configure.ac Makefile.am
- chmod +x debian/autogen.sh
- debian/autogen.sh
-
-config.status: configure
- dh_testdir
- rm -f config.cache
- $(configure)
-
-build: build-stamp
-
-build-stamp: config.status
- dh_testdir
- $(MAKE)
- touch $@
-
-clean: clean-patched
+cfg_opts := --prefix=/opt/vyatta
+cfg_opts += --libdir=/usr/lib
+cfg_opts += --includedir=/usr/include
+cfg_opts += --mandir=\$${prefix}/share/man
+cfg_opts += --infodir=\$${prefix}/share/info
+cfg_opts += CFLAGS="$(CFLAGS)"
+cfg_opts += LDFLAGS="-Wl,-z,defs"
+inst_opts := --sourcedir=debian/tmp
-# Clean everything up, including everything auto-generated
-# at build time that needs not to be kept around in the Debian diff
-clean-patched:
- dh_testdir
- dh_testroot
- if test -f Makefile ; then $(MAKE) clean distclean ; fi
- rm -f build-stamp
- rm -f config.status config.sub config.guess config.log
- rm -f aclocal.m4 configure Makefile.in Makefile INSTALL
- rm -rf config
- dh_clean
+clean:
+ dh clean
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- $(MAKE) DESTDIR=$(PKGDIR) install
-
- install -D --mode=0644 debian/lintian $(PKGDIR)/usr/share/lintian/overrides/$(PACKAGE)
- install -D --mode=0644 debian/linda $(PKGDIR)/usr/share/linda/overrides/$(PACKAGE)
-
-# Build architecture-independent files here.
-binary-indep: build install
+binary binary-arch binary-indep: install
rm -f debian/files
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_install
- dh_installdebconf
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
+ dh binary --before dh_gencontrol
+ rm -f debian/*/DEBIAN/conffiles
if [ -f "../.VYATTA_DEV_BUILD" ]; then \
dh_gencontrol -- -v999.dev; \
else \
dh_gencontrol; \
fi
- dh_md5sums
- dh_builddeb
+ dh binary --after dh_gencontrol
-# Build architecture-dependent files here.
-binary-arch: build install
-# This is an architecture independent package
-# so; we have nothing to do by default.
+build: Makefile
+build:
+ rm -f debian/*.debhelper*
+ dh build --before configure
+ dh build --after configure --before dh_auto_test
+ dh build --after dh_auto_test
+
+Makefile: Makefile.in
+ ./configure $(cfg_opts)
+
+Makefile.in: Makefile.am configure.ac
+ autoreconf -i --force
+
+install: build
+ dh install --before dh_install
+ dh_install $(inst_opts)
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install